summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-05-12 18:38:51 +0200
committerFelix Fietkau <nbd@nbd.name>2016-05-12 19:35:32 +0200
commit98010ab4898685ac32e8a27bb010c0872c401610 (patch)
treea79bfddbc2cb3c3ec1bf3c591f734c52a7c0bb7d /package/kernel/linux
parent3d6d5ccf593a1e2c537756002f82e96760daf4ac (diff)
downloadmaster-31e0f0ae-98010ab4898685ac32e8a27bb010c0872c401610.tar.gz
master-31e0f0ae-98010ab4898685ac32e8a27bb010c0872c401610.tar.bz2
master-31e0f0ae-98010ab4898685ac32e8a27bb010c0872c401610.zip
kernel: remove ocf support, cryptodev-linux should be used instead
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/crypto.mk48
1 files changed, 0 insertions, 48 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 0acc730691..e144d64dfb 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -631,54 +631,6 @@ endif
$(eval $(call KernelPackage,crypto-misc))
-define KernelPackage/crypto-ocf
- TITLE:=OCF modules
- DEPENDS:=+@OPENSSL_ENGINE_CRYPTO @!TARGET_uml +kmod-crypto-manager
- KCONFIG:= \
- CONFIG_OCF_OCF \
- CONFIG_OCF_CRYPTODEV \
- CONFIG_OCF_CRYPTOSOFT \
- CONFIG_OCF_FIPS=y \
- CONFIG_OCF_RANDOMHARVEST=y
- FILES:= \
- $(LINUX_DIR)/crypto/ocf/ocf.ko \
- $(LINUX_DIR)/crypto/ocf/cryptodev.ko \
- $(LINUX_DIR)/crypto/ocf/cryptosoft.ko
- AUTOLOAD:=$(call AutoLoad,09, \
- ocf \
- cryptodev \
- cryptosoft \
- )
- $(call AddDepends/crypto)
-endef
-
-$(eval $(call KernelPackage,crypto-ocf))
-
-
-define KernelPackage/crypto-ocf-hifn7751
- TITLE:=OCF support for Hifn 6500/7751/7811/795x, Invertex AEON and NetSec 7751 devices
- DEPENDS:=+@OPENSSL_ENGINE_CRYPTO @PCI_SUPPORT @!TARGET_uml kmod-crypto-ocf
- KCONFIG:=CONFIG_OCF_HIFN
- FILES:=$(LINUX_DIR)/crypto/ocf/hifn/hifn7751.ko
- AUTOLOAD:=$(call AutoLoad,10,hifn7751)
- $(call AddDepends/crypto)
-endef
-
-$(eval $(call KernelPackage,crypto-ocf-hifn7751))
-
-
-define KernelPackage/crypto-ocf-hifnhipp
- TITLE:=OCF support for Hifn 7855/8155 devices
- DEPENDS:=+@OPENSSL_ENGINE_CRYPTO @PCI_SUPPORT @!TARGET_uml kmod-crypto-ocf
- KCONFIG:=CONFIG_OCF_HIFNHIPP
- FILES:=$(LINUX_DIR)/crypto/ocf/hifn/hifnHIPP.ko
- AUTOLOAD:=$(call AutoLoad,10,hifnHIPP)
- $(call AddDepends/crypto)
-endef
-
-$(eval $(call KernelPackage,crypto-ocf-hifnhipp))
-
-
define KernelPackage/crypto-null
TITLE:=Null CryptoAPI module
KCONFIG:=CONFIG_CRYPTO_NULL