summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorDaniel Dickinson <lede@daniel.thecshore.com>2016-05-18 04:46:41 -0400
committerJo-Philipp Wich <jo@mein.io>2016-05-18 22:17:28 +0200
commit83049ed944f19bddeb9bc012b2a18e5df080d317 (patch)
tree373c34c6b25bbb3fcb5ea73a28152e759c85d8a2 /package/kernel/linux
parent638d5098178bf8383987c90f104bf6fa5108922c (diff)
downloadmaster-31e0f0ae-83049ed944f19bddeb9bc012b2a18e5df080d317.tar.gz
master-31e0f0ae-83049ed944f19bddeb9bc012b2a18e5df080d317.tar.bz2
master-31e0f0ae-83049ed944f19bddeb9bc012b2a18e5df080d317.zip
kernel: Build it87 hardware monitor module
Add packaging of it87 hardware monitor kernel module. It is a common thermal and voltage monitor that is in many x86 (at least) devices, and is just another i2c hwmon module. Signed-off-by: Daniel Dickinson <lede@daniel.thecshore.com>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/hwmon.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 69aaacd92f..f7a92eda1e 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -108,6 +108,20 @@ endef
$(eval $(call KernelPackage,hwmon-ina2xx))
+define KernelPackage/hwmon-it87
+ TITLE:=IT87 monitoring support
+ KCONFIG:=CONFIG_SENSORS_IT87
+ FILES:=$(LINUX_DIR)/drivers/hwmon/it87.ko
+ AUTOLOAD:=$(call AutoProbe,it87)
+ $(call AddDepends/hwmon,+kmod-i2c-core +kmod-hwmon-vid +PACKAGE_kmod-thermal:kmod-thermal)
+endef
+
+define KernelPackage/hwmon-it87/description
+ Kernel module for it87 thermal and voltage monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-it87))
+
define KernelPackage/hwmon-lm63
TITLE:=LM63/64 monitoring support
KCONFIG:=CONFIG_SENSORS_LM63