summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-05-12 16:52:36 +0200
committerFelix Fietkau <nbd@nbd.name>2016-05-12 17:00:53 +0200
commit7d7fb75df5735a089d183ca3d24c06d4b5178dc8 (patch)
treec0c12b4981f38bfa2376363fb8bea3b2184661a0 /package/kernel/linux
parent959bc143a019f23e9faac79e475b269e2a7efabc (diff)
downloadmaster-31e0f0ae-7d7fb75df5735a089d183ca3d24c06d4b5178dc8.tar.gz
master-31e0f0ae-7d7fb75df5735a089d183ca3d24c06d4b5178dc8.tar.bz2
master-31e0f0ae-7d7fb75df5735a089d183ca3d24c06d4b5178dc8.zip
x86: remove the kvm_guest subtarget
32-bit only hardware that supports kvm is very rare. It's not worth keeping a separate subtarget for this. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/virtual.mk48
1 files changed, 0 insertions, 48 deletions
diff --git a/package/kernel/linux/modules/virtual.mk b/package/kernel/linux/modules/virtual.mk
index 61a8a87609..e18c376d3e 100644
--- a/package/kernel/linux/modules/virtual.mk
+++ b/package/kernel/linux/modules/virtual.mk
@@ -7,54 +7,6 @@
VIRTUAL_MENU:=Virtualization Support
-define KernelPackage/virtio-balloon
- SUBMENU:=$(VIRTUAL_MENU)
- TITLE:=VirtIO balloon driver
- DEPENDS:=@TARGET_x86_kvm_guest
- KCONFIG:=CONFIG_VIRTIO_BALLOON
- FILES:=$(LINUX_DIR)/drivers/virtio/virtio_balloon.ko
- AUTOLOAD:=$(call AutoLoad,06,virtio-balloon)
-endef
-
-define KernelPackage/virtio-balloon/description
- Kernel module for VirtIO memory ballooning support
-endef
-
-$(eval $(call KernelPackage,virtio-balloon))
-
-
-define KernelPackage/virtio-net
- SUBMENU:=$(VIRTUAL_MENU)
- TITLE:=VirtIO network driver
- DEPENDS:=@TARGET_x86_kvm_guest
- KCONFIG:=CONFIG_VIRTIO_NET
- FILES:=$(LINUX_DIR)/drivers/net/virtio_net.ko
- AUTOLOAD:=$(call AutoLoad,50,virtio_net)
-endef
-
-define KernelPackage/virtio-net/description
- Kernel module for the VirtIO paravirtualized network device
-endef
-
-$(eval $(call KernelPackage,virtio-net))
-
-
-define KernelPackage/virtio-random
- SUBMENU:=$(VIRTUAL_MENU)
- TITLE:=VirtIO Random Number Generator support
- DEPENDS:=@TARGET_x86_kvm_guest
- KCONFIG:=CONFIG_HW_RANDOM_VIRTIO
- FILES:=$(LINUX_DIR)/drivers/char/hw_random/virtio-rng.ko
- AUTOLOAD:=$(call AutoLoad,09,virtio-rng)
-endef
-
-define KernelPackage/virtio-random/description
- Kernel module for the VirtIO Random Number Generator
-endef
-
-$(eval $(call KernelPackage,virtio-random))
-
-
define KernelPackage/xen-privcmd
SUBMENU:=$(VIRTUAL_MENU)
TITLE:=Xen private commands