summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-12-11 18:35:41 +0000
committerJohn Crispin <john@openwrt.org>2014-12-11 18:35:41 +0000
commit6d52fd203d11c715981d7aea817401ad234c2181 (patch)
tree39b75e4dc22f50ab5e7991071e84e2853c442a49 /package/kernel/linux
parented61e202a1d7185374a33ebe86a3d8c1640e47b3 (diff)
downloadmaster-31e0f0ae-6d52fd203d11c715981d7aea817401ad234c2181.tar.gz
master-31e0f0ae-6d52fd203d11c715981d7aea817401ad234c2181.tar.bz2
master-31e0f0ae-6d52fd203d11c715981d7aea817401ad234c2181.zip
kernel/modules: fix chipidea
it should needs to depend on imx and mxs also remove duplicate kmod definition from mxs target Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 43627
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/usb.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 4644cbbe16..c700570375 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -1401,9 +1401,9 @@ endef
$(eval $(call KernelPackage,usbip-server))
-define KernelPackage/usb-chipidea
+define KernelPackage/usb-chipidea-imx
TITLE:=Support for ChipIdea controllers
- DEPENDS:=+kmod-usb2 +USB_GADGET_SUPPORT:kmod-usb-gadget
+ DEPENDS:=@TARGET_imx6||TARGET_mxs +kmod-usb2 +USB_GADGET_SUPPORT:kmod-usb-gadget
KCONFIG:=\
CONFIG_USB_CHIPIDEA \
CONFIG_USB_CHIPIDEA_HOST=y \
@@ -1424,12 +1424,12 @@ else
endif
$(call AddDepends/usb)
endef
-
-define KernelPackage/usb-chipidea/description
+
+define KernelPackage/usb-chipidea-imx/description
Kernel support for USB ChipIdea controllers
endef
-$(eval $(call KernelPackage,usb-chipidea,1))
+$(eval $(call KernelPackage,usb-chipidea-imx,1))
define KernelPackage/usb-mxs-phy