summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-02-15 18:45:34 +0000
committerJohn Crispin <john@openwrt.org>2016-02-15 18:45:34 +0000
commit5902afcfca557872b76c7c4391b14ceb5273b7e2 (patch)
tree208721b7a38d5acd085a1eaca1ebfc8b69f475e9 /package/kernel/linux/modules
parent6b90cc026847311de49f0efa67186bfd853c43e3 (diff)
downloadmaster-31e0f0ae-5902afcfca557872b76c7c4391b14ceb5273b7e2.tar.gz
master-31e0f0ae-5902afcfca557872b76c7c4391b14ceb5273b7e2.tar.bz2
master-31e0f0ae-5902afcfca557872b76c7c4391b14ceb5273b7e2.zip
kernel: add missing libphy dep to DSA
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 48723
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/dsa.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/dsa.mk b/package/kernel/linux/modules/dsa.mk
index 0696d754d5..5f19a3f7b4 100644
--- a/package/kernel/linux/modules/dsa.mk
+++ b/package/kernel/linux/modules/dsa.mk
@@ -18,6 +18,7 @@ define KernelPackage/dsa
CONFIG_NET_DSA \
CONFIG_NET_SWITCHDEV=y \
CONFIG_NET_DSA_HWMON=n
+ DEPENDS:=+kmod-libphy
FILES:=$(LINUX_DIR)/net/dsa/dsa_core.ko
AUTOLOAD:=$(call AutoLoad,34,dsa_core)
endef