summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/wpan.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-25 12:41:19 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-25 12:41:19 +0000
commit827672162a1548676b78808786f0698b85873269 (patch)
treee865802064d6aeee310520c5fa1c580762e666c0 /package/kernel/linux/modules/wpan.mk
parentb7ab6c66cc8b0b89c623c1270b60ed61024cfe41 (diff)
downloadmaster-31e0f0ae-827672162a1548676b78808786f0698b85873269.tar.gz
master-31e0f0ae-827672162a1548676b78808786f0698b85873269.tar.bz2
master-31e0f0ae-827672162a1548676b78808786f0698b85873269.zip
kernel: wpan: mrf24j40 depends on regmap-spi
kmod-mrf24j40 select REGMAP_SPI since 4.3, thus add dependency to kmod-regmap. Found by buildbot: Package kmod-mrf24j40 is missing dependencies for the following libraries: regmap-spi.ko Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 48484
Diffstat (limited to 'package/kernel/linux/modules/wpan.mk')
-rw-r--r--package/kernel/linux/modules/wpan.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/wpan.mk b/package/kernel/linux/modules/wpan.mk
index 58fe8eb9d8..199044fc33 100644
--- a/package/kernel/linux/modules/wpan.mk
+++ b/package/kernel/linux/modules/wpan.mk
@@ -85,7 +85,7 @@ $(eval $(call KernelPackage,at86rf230))
define KernelPackage/mrf24j40
SUBMENU:=$(WPAN_MENU)
TITLE:=MRF24J40 transceiver driver
- DEPENDS:=+kmod-mac802154
+ DEPENDS:=+kmod-mac802154 +kmod-regmap
KCONFIG:=CONFIG_IEEE802154_MRF24J40 \
CONFIG_SPI=y \
CONFIG_SPI_MASTER=y