summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/video.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-29 08:12:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-29 08:12:39 +0000
commit13e7b6d77da41b47ccd7947d208b3d4eaea29b81 (patch)
tree89622022be01ea17f6ebd6f1afcb2dd15c9fcee9 /package/kernel/linux/modules/video.mk
parent0b39a6d4e95c1969550eea89238a2f7c34433be2 (diff)
downloadmaster-31e0f0ae-13e7b6d77da41b47ccd7947d208b3d4eaea29b81.tar.gz
master-31e0f0ae-13e7b6d77da41b47ccd7947d208b3d4eaea29b81.tar.bz2
master-31e0f0ae-13e7b6d77da41b47ccd7947d208b3d4eaea29b81.zip
kernel: remove useless AddDepends/input abstraction
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45135
Diffstat (limited to 'package/kernel/linux/modules/video.mk')
-rw-r--r--package/kernel/linux/modules/video.mk3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index 25ef9cb7dc..7a7d80c534 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -184,12 +184,11 @@ $(eval $(call KernelPackage,video-pwc))
define KernelPackage/video-uvc
TITLE:=USB Video Class (UVC) support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-video-videobuf2
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-video-videobuf2 +kmod-input-core
KCONFIG:= CONFIG_USB_VIDEO_CLASS
FILES:=$(LINUX_DIR)/drivers/media/$(V4L2_USB_DIR)/uvc/uvcvideo.ko
AUTOLOAD:=$(call AutoProbe,uvcvideo)
$(call AddDepends/camera)
- $(call AddDepends/input)
endef
define KernelPackage/video-uvc/description