summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-05-23 15:28:26 +0000
committerJohn Crispin <john@openwrt.org>2015-05-23 15:28:26 +0000
commitc0b0ee9d9e6c66ab774502d79c07ef35092b9a18 (patch)
tree6e975df2aef2e0f8c3ad2d2e90e9f15e5046c136 /package/kernel/linux/modules/usb.mk
parentab84e2d70455743ba457fff4e55fe14aec4a4d61 (diff)
downloadmaster-31e0f0ae-c0b0ee9d9e6c66ab774502d79c07ef35092b9a18.tar.gz
master-31e0f0ae-c0b0ee9d9e6c66ab774502d79c07ef35092b9a18.tar.bz2
master-31e0f0ae-c0b0ee9d9e6c66ab774502d79c07ef35092b9a18.zip
modules/usb: cleanup remove old module names
delete cases for Kernel <3.10 (nop-usb-xceiv), <3.12 (phy-nop) Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> SVN-Revision: 45733
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk10
1 files changed, 0 insertions, 10 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 589894bcd1..f3c84e6f10 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -103,18 +103,8 @@ define KernelPackage/usb-phy-nop
TITLE:=Support for USB NOP transceiver
KCONFIG:=CONFIG_NOP_USB_XCEIV
HIDDEN:=1
-ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/phy/phy-generic.ko),)
FILES:=$(LINUX_DIR)/drivers/usb/phy/phy-generic.ko
AUTOLOAD:=$(call AutoLoad,43,phy-generic)
-else
-ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/phy/phy-nop.ko),)
- FILES:=$(LINUX_DIR)/drivers/usb/phy/phy-nop.ko
- AUTOLOAD:=$(call AutoLoad,43,phy-nop)
-else
- FILES:=$(LINUX_DIR)/drivers/usb/otg/nop-usb-xceiv.ko
- AUTOLOAD:=$(call AutoLoad,43,nop-usb-xceiv)
-endif
-endif
$(call AddDepends/usb)
endef