summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-10-19 10:10:51 +0000
committerJohn Crispin <john@openwrt.org>2015-10-19 10:10:51 +0000
commit795cc23a08b7e70743a125bc4f9c2fa7d284a26c (patch)
tree893d0e1888f4e41363442dd765c81b160949a34e /package/kernel/linux/modules/usb.mk
parent5c338cb0d82ace6b43988dc95925b0d541e7cbfa (diff)
downloadmaster-31e0f0ae-795cc23a08b7e70743a125bc4f9c2fa7d284a26c.tar.gz
master-31e0f0ae-795cc23a08b7e70743a125bc4f9c2fa7d284a26c.tar.bz2
master-31e0f0ae-795cc23a08b7e70743a125bc4f9c2fa7d284a26c.zip
kernel: add usb-mass-storage-gadget driver package
This is another useful gadget driver that can allow an OTG port to act as a mass storage device. Signed-off-by: Pushpal Sidhu <psidhu@gateworks.com> SVN-Revision: 47225
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 986f53f226..487a17de10 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -279,6 +279,23 @@ endef
$(eval $(call KernelPackage,usb-serial-gadget))
+define KernelPackage/usb-mass-storage-gadget
+ TITLE:=USB Mass Storage support
+ KCONFIG:=CONFIG_USB_MASS_STORAGE
+ DEPENDS:=+kmod-usb-gadget +kmod-usb-lib-composite
+ FILES:= \
+ $(LINUX_DIR)/drivers/usb/gadget/function/usb_f_mass_storage.ko \
+ $(LINUX_DIR)/drivers/usb/gadget/legacy/g_mass_storage.ko
+ AUTOLOAD:=$(call AutoLoad,52,usb_f_mass_storage g_mass_storage)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb-mass-storage-gadget/description
+ Kernel support for USB Gadget Mass Storage
+endef
+
+$(eval $(call KernelPackage,usb-mass-storage-gadget))
+
define KernelPackage/usb-uhci
TITLE:=Support for UHCI controllers