summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-04-02 14:31:10 +0000
committerJohn Crispin <john@openwrt.org>2015-04-02 14:31:10 +0000
commit63442803af9930234523a20bea89c4f3d46fee56 (patch)
tree4d3caebf409aeea36fecd3f8bee69f309621e7ad /package/kernel/linux/modules/usb.mk
parent023a05fe7a2f9f4a90ef385a7366655d3aa26b9e (diff)
downloadmaster-31e0f0ae-63442803af9930234523a20bea89c4f3d46fee56.tar.gz
master-31e0f0ae-63442803af9930234523a20bea89c4f3d46fee56.tar.bz2
master-31e0f0ae-63442803af9930234523a20bea89c4f3d46fee56.zip
kernel: add garmin_gps module
OpenWrt on sailboats requested: https://forum.openwrt.org/viewtopic.php?id=56586 Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> SVN-Revision: 45232
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index e3d7165f47..fc47568dbc 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -631,6 +631,21 @@ endef
$(eval $(call KernelPackage,usb-serial-ftdi))
+define KernelPackage/usb-serial-garmin
+ TITLE:=Support for Garmin GPS devices
+ KCONFIG:=CONFIG_USB_SERIAL_GARMIN
+ FILES:=$(LINUX_DIR)/drivers/usb/serial/garmin_gps.ko
+ AUTOLOAD:=$(call AutoProbe,garmin_gps)
+ $(call AddDepends/usb-serial)
+endef
+
+define KernelPackage/usb-serial-garmin/description
+ Should work with most Garmin GPS devices which have a native USB port.
+endef
+
+$(eval $(call KernelPackage,usb-serial-garmin))
+
+
define KernelPackage/usb-serial-ti-usb
TITLE:=Support for TI USB 3410/5052
KCONFIG:=CONFIG_USB_SERIAL_TI