summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2014-11-17 14:30:19 +0000
committerJohn Crispin <john@openwrt.org>2014-11-17 14:30:19 +0000
commit45462e9c993948928d64d3acfee94bfe48fb1600 (patch)
tree193588ead980aa9931b18753d06181d506d7c137 /package/kernel/linux/modules/usb.mk
parent5d2c8101011425ddc25700493966c988ed476fe4 (diff)
downloadmaster-31e0f0ae-45462e9c993948928d64d3acfee94bfe48fb1600.tar.gz
master-31e0f0ae-45462e9c993948928d64d3acfee94bfe48fb1600.tar.bz2
master-31e0f0ae-45462e9c993948928d64d3acfee94bfe48fb1600.zip
kernel/modules: location of usb-common.ko changed
usb-common.ko was moved to drivers/usb/common starting from kernel 3.16 by upstream commit f4cbd33fd5f0587910fa9db403a1b42f1cabf820 Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 43290
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index cc7092ec5a..74de4461fb 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -16,9 +16,15 @@ define KernelPackage/usb-core
TITLE:=Support for USB
DEPENDS:=@USB_SUPPORT
KCONFIG:=CONFIG_USB CONFIG_XPS_USB_HCD_XILINX=n CONFIG_USB_FHCI_HCD=n
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.16.0)),1)
+ FILES:= \
+ $(LINUX_DIR)/drivers/usb/core/usbcore.ko \
+ $(LINUX_DIR)/drivers/usb/common/usb-common.ko
+else
FILES:= \
$(LINUX_DIR)/drivers/usb/core/usbcore.ko \
$(LINUX_DIR)/drivers/usb/usb-common.ko
+endif
AUTOLOAD:=$(call AutoLoad,20,usb-common usbcore,1)
$(call AddDepends/nls)
endef