summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-28 13:13:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-28 13:13:14 +0000
commit305e8b724ae5b8448db48e040f3521f9e8051cc9 (patch)
treefe20d8ccc459af8501066d86e523071b5d378911 /package/kernel/linux/modules/usb.mk
parent02ba90c22866f8c272e93af591f236a50718af4c (diff)
downloadmaster-31e0f0ae-305e8b724ae5b8448db48e040f3521f9e8051cc9.tar.gz
master-31e0f0ae-305e8b724ae5b8448db48e040f3521f9e8051cc9.tar.bz2
master-31e0f0ae-305e8b724ae5b8448db48e040f3521f9e8051cc9.zip
kernel: fix USB on mpc85xx (#21689)
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48525
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 1fdf7462a8..822182902c 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -367,9 +367,11 @@ define KernelPackage/usb2-fsl
DEPENDS:=@TARGET_mpc85xx
KCONFIG:=\
CONFIG_USB_FSL_MPH_DR_OF \
- CONFIG_USB_EHCI_FSL=y
- FILES:=$(LINUX_DIR)/drivers/usb/host/fsl-mph-dr-of.ko
- AUTOLOAD:=$(call AutoLoad,39,fsl-mph-dr-of,1)
+ CONFIG_USB_EHCI_FSL
+ FILES:= \
+ $(LINUX_DIR)/drivers/usb/host/ehci-fsl.ko \
+ $(LINUX_DIR)/drivers/usb/host/fsl-mph-dr-of.ko
+ AUTOLOAD:=$(call AutoLoad,39,ehci-fsl fsl-mph-dr-of,1)
$(call AddDepends/usb)
endef