summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/usb.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-04-04 05:20:34 +0000
committerJohn Crispin <john@openwrt.org>2015-04-04 05:20:34 +0000
commit0e78550030b336016ca3736062a3fea4ce174bf3 (patch)
treeb72ea3a53218f1507a57302ecb6fdb918d049ee9 /package/kernel/linux/modules/usb.mk
parent67f4c4b99232b00f7e772c292f3c17d1d9b44a46 (diff)
downloadmaster-31e0f0ae-0e78550030b336016ca3736062a3fea4ce174bf3.tar.gz
master-31e0f0ae-0e78550030b336016ca3736062a3fea4ce174bf3.tar.bz2
master-31e0f0ae-0e78550030b336016ca3736062a3fea4ce174bf3.zip
kernel: fix dwc3 symbols
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 45268
Diffstat (limited to 'package/kernel/linux/modules/usb.mk')
-rw-r--r--package/kernel/linux/modules/usb.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 46cd382aed..95ccb8422b 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -497,6 +497,9 @@ define KernelPackage/usb-dwc3
TITLE:=DWC3 USB controller driver
KCONFIG:= \
CONFIG_USB_DWC3 \
+ CONFIG_USB_DWC3_HOST=y \
+ CONFIG_USB_DWC3_GADGET=n \
+ CONFIG_USB_DWC3_DUAL_ROLE=n \
CONFIG_USB_DWC3_DEBUG=n \
CONFIG_USB_DWC3_VERBOSE=n
FILES:= $(LINUX_DIR)/drivers/usb/dwc3/dwc3.ko