summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/spi.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-09-17 21:45:17 +0000
committerJohn Crispin <john@openwrt.org>2013-09-17 21:45:17 +0000
commitf12f4074aff6536a8056689406197809be373685 (patch)
tree6eb3cbac436078263f88872d19e367de1a15c512 /package/kernel/linux/modules/spi.mk
parent022cadd64e8a24818d15b22bc28f3460e0b2519c (diff)
downloadmaster-31e0f0ae-f12f4074aff6536a8056689406197809be373685.tar.gz
master-31e0f0ae-f12f4074aff6536a8056689406197809be373685.tar.bz2
master-31e0f0ae-f12f4074aff6536a8056689406197809be373685.zip
kernel: make most modules use AutoProbe
now that we have modprobe we can set more than half of the modules to AutoProbe Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 38021
Diffstat (limited to 'package/kernel/linux/modules/spi.mk')
-rw-r--r--package/kernel/linux/modules/spi.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/package/kernel/linux/modules/spi.mk b/package/kernel/linux/modules/spi.mk
index cae6bc632f..1c2a789fed 100644
--- a/package/kernel/linux/modules/spi.mk
+++ b/package/kernel/linux/modules/spi.mk
@@ -17,7 +17,7 @@ define KernelPackage/mmc-spi
FILES:=\
$(if $(CONFIG_OF),$(LINUX_DIR)/drivers/mmc/host/of_mmc_spi.ko) \
$(LINUX_DIR)/drivers/mmc/host/mmc_spi.ko
- AUTOLOAD:=$(call AutoLoad,90,$(if $(CONFIG_OF),of_mmc_spi) mmc_spi)
+ AUTOLOAD:=$(call AutoProbe,$(if $(CONFIG_OF),of_mmc_spi) mmc_spi)
endef
define KernelPackage/mmc-spi/description
@@ -34,7 +34,6 @@ define KernelPackage/spi-bitbang
CONFIG_SPI=y \
CONFIG_SPI_MASTER=y
FILES:=$(LINUX_DIR)/drivers/spi/spi-bitbang.ko
- AUTOLOAD:=$(call AutoLoad,91,spi-bitbang)
endef
define KernelPackage/spi-bitbang/description
@@ -50,7 +49,7 @@ define KernelPackage/spi-gpio-old
DEPENDS:=@GPIO_SUPPORT +kmod-spi-bitbang
KCONFIG:=CONFIG_SPI_GPIO_OLD
FILES:=$(LINUX_DIR)/drivers/spi/spi_gpio_old.ko
- AUTOLOAD:=$(call AutoLoad,92,spi_gpio_old)
+ AUTOLOAD:=$(call AutoProbe,spi_gpio_old)
endef
define KernelPackage/spi-gpio-old/description
@@ -66,7 +65,7 @@ define KernelPackage/spi-gpio
DEPENDS:=@GPIO_SUPPORT +kmod-spi-bitbang
KCONFIG:=CONFIG_SPI_GPIO
FILES:=$(LINUX_DIR)/drivers/spi/spi-gpio.ko
- AUTOLOAD:=$(call AutoLoad,92,spi-gpio)
+ AUTOLOAD:=$(call AutoProbe,spi-gpio)
endef
define KernelPackage/spi-gpio/description
@@ -82,7 +81,7 @@ define KernelPackage/spi-dev
CONFIG_SPI=y \
CONFIG_SPI_MASTER=y
FILES:=$(LINUX_DIR)/drivers/spi/spidev.ko
- AUTOLOAD:=$(call AutoLoad,93,spidev)
+ AUTOLOAD:=$(call AutoProbe,spidev)
endef
define KernelPackage/spi-dev/description