summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-12-11 15:05:53 +0000
committerJohn Crispin <john@openwrt.org>2015-12-11 15:05:53 +0000
commitf03bf608b15125049fe5b9e9b79db1a9d0750182 (patch)
tree8aa3ab7d1c062551935ac136b64b51a7c6d80f13 /package/kernel/linux/modules/sound.mk
parent0938233fcdef67d969f9429a10761cc640c6d56d (diff)
downloadmaster-31e0f0ae-f03bf608b15125049fe5b9e9b79db1a9d0750182.tar.gz
master-31e0f0ae-f03bf608b15125049fe5b9e9b79db1a9d0750182.tar.bz2
master-31e0f0ae-f03bf608b15125049fe5b9e9b79db1a9d0750182.zip
kernel: Add dummy sound driver
Useful when using sound players that can send to icecast, etc. without any sound device attached. Signed-off-by: Ted Hess <thess@kitschensync.net> SVN-Revision: 47852
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 603bb7045c..d09cf21aba 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -273,3 +273,19 @@ define KernelPackage/pcspkr/description
endef
$(eval $(call KernelPackage,pcspkr))
+
+define KernelPackage/sound-dummy
+ $(call AddDepends/sound)
+ TITLE:=Null sound output driver (sink)
+ KCONFIG:= \
+ CONFIG_SND_DUMMY
+ FILES:= \
+ $(LINUX_DIR)/sound/drivers/snd-dummy.ko
+ AUTOLOAD:=$(call AutoLoad,32,snd-dummy)
+endef
+
+define KernelPackage/sound_dummy/description
+ Dummy sound device for Alsa when no hardware present
+endef
+
+$(eval $(call KernelPackage,sound-dummy))