summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2014-03-20 23:15:56 +0000
committerFlorian Fainelli <florian@openwrt.org>2014-03-20 23:15:56 +0000
commitee37a00d06c72a3e52a1fd0cfcb5360882f51046 (patch)
tree695363047047b80239ec5c2913258327417851f3 /package/kernel/linux/modules/sound.mk
parenta51ffcc1d118890228c95bc8c552a49fd5a676d2 (diff)
downloadmaster-31e0f0ae-ee37a00d06c72a3e52a1fd0cfcb5360882f51046.tar.gz
master-31e0f0ae-ee37a00d06c72a3e52a1fd0cfcb5360882f51046.tar.bz2
master-31e0f0ae-ee37a00d06c72a3e52a1fd0cfcb5360882f51046.zip
modules: make kmod-pcspkr depend on X86
The kernel Kconfig dependency lists X86, and we will fail building this module on other platforms such as Malta. Signed-off-by: Florian Fainelli <florian@openwrt.org> SVN-Revision: 39974
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 777d274a4e..ebdd3d9fe3 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -262,7 +262,7 @@ $(eval $(call KernelPackage,sound-soc-gw_avila))
define KernelPackage/pcspkr
- DEPENDS:=@!TARGET_x86
+ DEPENDS:=@TARGET_x86
TITLE:=PC speaker support
KCONFIG:= \
CONFIG_INPUT_PCSPKR \