summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-07-15 23:18:34 +0000
committerLuka Perkov <luka@openwrt.org>2013-07-15 23:18:34 +0000
commitd530ad07325ca318a677f637c65d7fef86436548 (patch)
tree713269172a6493af0b1b90632fdca516ec3cceb8 /package/kernel/linux/modules/sound.mk
parentb3ec189cdb19b20c0d020fc4bcdfaac0652e4114 (diff)
downloadmaster-31e0f0ae-d530ad07325ca318a677f637c65d7fef86436548.tar.gz
master-31e0f0ae-d530ad07325ca318a677f637c65d7fef86436548.tar.bz2
master-31e0f0ae-d530ad07325ca318a677f637c65d7fef86436548.zip
kernel: add sound-soc-imx-sgtl5000
Signed-off-by: Tim Harvey <tharvey@gateworks.com> SVN-Revision: 37360
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 74de21f2ad..ca5b5d236c 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -201,6 +201,22 @@ endef
$(eval $(call KernelPackage,sound-soc-imx))
+define KernelPackage/sound-soc-imx-sgtl5000
+ TITLE:=IMX SoC support for SGTL5000
+ KCONFIG:=CONFIG_SND_SOC_IMX_SGTL5000
+ FILES:=$(LINUX_DIR)/sound/soc/codecs/snd-soc-sgtl5000.ko
+ AUTOLOAD:=$(call AutoLoad,57,snd-soc-sgtl5000)
+ DEPENDS:=@TARGET_imx6 +kmod-sound-soc-imx
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-soc-imx-sgtl5000/description
+ support for i.MX6 Platform sound SGTL5000 codec
+endef
+
+$(eval $(call KernelPackage,sound-soc-imx-sgtl5000))
+
+
define KernelPackage/sound-soc-gw_avila
TITLE:=Gateworks Avila SoC sound support
KCONFIG:= \