summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-12-09 11:30:18 +0000
committerLuka Perkov <luka@openwrt.org>2013-12-09 11:30:18 +0000
commit98009790c66ec83cedf21af9fadf63049c5f23fd (patch)
treecf72f527c8e6f6baa9e46fbe17eda76827fbd180 /package/kernel/linux/modules/sound.mk
parentef5e13325ef7e4bf9f720ae89433dff8769c3781 (diff)
downloadmaster-31e0f0ae-98009790c66ec83cedf21af9fadf63049c5f23fd.tar.gz
master-31e0f0ae-98009790c66ec83cedf21af9fadf63049c5f23fd.tar.bz2
master-31e0f0ae-98009790c66ec83cedf21af9fadf63049c5f23fd.zip
kernel: module updates for 3.12
Signed-off-by: Tim Harvey <tharvey@gateworks.com> SVN-Revision: 39008
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index bed2e3c802..777d274a4e 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -190,6 +190,7 @@ $(eval $(call KernelPackage,sound-soc-ac97))
define KernelPackage/sound-soc-imx
TITLE:=IMX SoC support
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),lt,3.12.0)),1)
KCONFIG:=\
CONFIG_SND_IMX_SOC \
CONFIG_SND_SOC_IMX_AUDMUX \
@@ -200,6 +201,18 @@ define KernelPackage/sound-soc-imx
$(LINUX_DIR)/sound/soc/fsl/snd-soc-fsl-ssi.ko \
$(LINUX_DIR)/sound/soc/fsl/snd-soc-imx-pcm.ko
AUTOLOAD:=$(call AutoLoad,56,snd-soc-imx-audmux snd-soc-fsl-ssi snd-soc-imx-pcm)
+else
+ KCONFIG:=\
+ CONFIG_SND_IMX_SOC \
+ CONFIG_SND_SOC_IMX_AUDMUX \
+ CONFIG_SND_SOC_FSL_SSI \
+ CONFIG_SND_SOC_IMX_PCM_DMA
+ FILES:= \
+ $(LINUX_DIR)/sound/soc/fsl/snd-soc-imx-audmux.ko \
+ $(LINUX_DIR)/sound/soc/fsl/snd-soc-fsl-ssi.ko \
+ $(LINUX_DIR)/sound/soc/fsl/imx-pcm-dma.ko
+ AUTOLOAD:=$(call AutoLoad,56,snd-soc-imx-audmux snd-soc-fsl-ssi snd-soc-imx-pcm)
+endif
DEPENDS:=@TARGET_imx6 +kmod-sound-soc-core
$(call AddDepends/sound)
endef