summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/sound.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-29 08:12:39 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-29 08:12:39 +0000
commit13e7b6d77da41b47ccd7947d208b3d4eaea29b81 (patch)
tree89622022be01ea17f6ebd6f1afcb2dd15c9fcee9 /package/kernel/linux/modules/sound.mk
parent0b39a6d4e95c1969550eea89238a2f7c34433be2 (diff)
downloadmaster-31e0f0ae-13e7b6d77da41b47ccd7947d208b3d4eaea29b81.tar.gz
master-31e0f0ae-13e7b6d77da41b47ccd7947d208b3d4eaea29b81.tar.bz2
master-31e0f0ae-13e7b6d77da41b47ccd7947d208b3d4eaea29b81.zip
kernel: remove useless AddDepends/input abstraction
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45135
Diffstat (limited to 'package/kernel/linux/modules/sound.mk')
-rw-r--r--package/kernel/linux/modules/sound.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 9a3caed32a..54bc30ac32 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -51,7 +51,7 @@ endif
define KernelPackage/sound-core
SUBMENU:=$(SOUND_MENU)
TITLE:=Sound support
- DEPENDS:=@AUDIO_SUPPORT
+ DEPENDS:=@AUDIO_SUPPORT +kmod-input-core
KCONFIG:= \
CONFIG_SOUND \
CONFIG_SND \
@@ -70,7 +70,6 @@ define KernelPackage/sound-core
CONFIG_SND_COMPRESS_OFFLOAD
FILES:=$(SOUNDCORE_FILES)
AUTOLOAD:=$(call AutoLoad,30,$(SOUNDCORE_LOAD))
- $(call AddDepends/input)
endef
define KernelPackage/sound-core/uml
@@ -233,7 +232,7 @@ $(eval $(call KernelPackage,sound-soc-gw_avila))
define KernelPackage/pcspkr
- DEPENDS:=@TARGET_x86
+ DEPENDS:=@TARGET_x86 +kmod-input-core
TITLE:=PC speaker support
KCONFIG:= \
CONFIG_INPUT_PCSPKR \
@@ -242,7 +241,6 @@ define KernelPackage/pcspkr
$(LINUX_DIR)/drivers/input/misc/pcspkr.ko \
$(LINUX_DIR)/sound/drivers/pcsp/snd-pcsp.ko
AUTOLOAD:=$(call AutoLoad,50,pcspkr snd-pcsp)
- $(call AddDepends/input)
$(call AddDepends/sound)
endef