summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-24 09:08:57 +0000
committerJohn Crispin <john@openwrt.org>2015-07-24 09:08:57 +0000
commit8c8a558591e6ec8a5b53069bd92b45d424352b5f (patch)
treefb5cd8288dac430dd1328f41c9bb6030b46352e3 /package/kernel/linux/modules/other.mk
parentcc42b1049b5605abe57c49b822a433c27997172d (diff)
downloadmaster-31e0f0ae-8c8a558591e6ec8a5b53069bd92b45d424352b5f.tar.gz
master-31e0f0ae-8c8a558591e6ec8a5b53069bd92b45d424352b5f.tar.bz2
master-31e0f0ae-8c8a558591e6ec8a5b53069bd92b45d424352b5f.zip
kmod-regmap: enable MMIO support
This adds MMIO support for kmod-regmap. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 46451
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 473f063f55..25b274a722 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -692,14 +692,16 @@ define KernelPackage/regmap
TITLE:=Generic register map support
DEPENDS:=+kmod-lib-lzo +kmod-i2c-core
KCONFIG:=CONFIG_REGMAP \
+ CONFIG_REGMAP_MMIO \
CONFIG_REGMAP_SPI \
CONFIG_REGMAP_I2C \
CONFIG_SPI=y
FILES:= \
$(LINUX_DIR)/drivers/base/regmap/regmap-core.ko \
$(LINUX_DIR)/drivers/base/regmap/regmap-i2c.ko \
+ $(LINUX_DIR)/drivers/base/regmap/regmap-mmio.ko \
$(if $(CONFIG_SPI),$(LINUX_DIR)/drivers/base/regmap/regmap-spi.ko)
- AUTOLOAD:=$(call AutoLoad,21,regmap-core regmap-i2c regmap-spi)
+ AUTOLOAD:=$(call AutoLoad,21,regmap-core regmap-i2c regmap-mmio regmap-spi)
endef
define KernelPackage/regmap/description