summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-25 18:00:35 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-25 18:00:35 +0000
commit7530971113842f44e7d1a33dfbfd977f6dfb8912 (patch)
tree3753cedd8d623f48c0ef81a978677d599574c604 /package/kernel/linux/modules/other.mk
parent4fcc9ce9ff2fc696bbbfc41aeaf5c08c0a39222b (diff)
downloadmaster-31e0f0ae-7530971113842f44e7d1a33dfbfd977f6dfb8912.tar.gz
master-31e0f0ae-7530971113842f44e7d1a33dfbfd977f6dfb8912.tar.bz2
master-31e0f0ae-7530971113842f44e7d1a33dfbfd977f6dfb8912.zip
package/kernel: add support for industrial-io and AD799x
Add support for industrial IO core and (still staging) driver for AD799x, a high precision I2C ADC family. Signed-off-by: Hartmut Knaack <knaack.h@gmx.de> [juhosg: update subject, reformat commit message] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38187
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk45
1 files changed, 45 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index b2d59560f3..293e517821 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -193,6 +193,51 @@ endef
$(eval $(call KernelPackage,gpio-pcf857x))
+define KernelPackage/iio-core
+ SUBMENU:=$(OTHER_MENU)
+ DEPENDS:=@!LINUX_3_3
+ TITLE:=Industrial IO core
+ KCONFIG:= \
+ CONFIG_IIO \
+ CONFIG_IIO_BUFFER=y \
+ CONFIG_IIO_KFIFO_BUF \
+ CONFIG_IIO_TRIGGER=y \
+ CONFIG_IIO_TRIGGERED_BUFFER
+ FILES:= \
+ $(LINUX_DIR)/drivers/iio/industrialio.ko \
+ $(LINUX_DIR)/drivers/iio/industrialio-triggered-buffer.ko \
+ $(LINUX_DIR)/drivers/iio/kfifo_buf.ko
+ AUTOLOAD:=$(call AutoLoad,55,industrialio kfifo_buf industrialio-triggered-buffer)
+endef
+
+define KernelPackage/iio-core/description
+ The industrial I/O subsystem provides a unified framework for
+ drivers for many different types of embedded sensors using a
+ number of different physical interfaces (i2c, spi, etc)
+endef
+
+$(eval $(call KernelPackage,iio-core))
+
+
+define KernelPackage/iio-ad799x
+ SUBMENU:=$(OTHER_MENU)
+ DEPENDS:=kmod-i2c-core kmod-iio-core
+ TITLE:=Analog Devices AD799x ADC driver
+ KCONFIG:= \
+ CONFIG_AD799X_RING_BUFFER=y \
+ CONFIG_AD799X
+ FILES:=$(LINUX_DIR)/drivers/staging/iio/adc/ad799x.ko
+ AUTOLOAD:=$(call AutoLoad,56,ad799x)
+endef
+
+define KernelPackage/iio-ad799x/description
+ support for Analog Devices:
+ ad7991, ad7995, ad7999, ad7992, ad7993, ad7994, ad7997, ad7998
+ i2c analog to digital converters (ADC). WARNING! This driver is still staging!
+endef
+
+$(eval $(call KernelPackage,iio-ad799x))
+
define KernelPackage/lp
SUBMENU:=$(OTHER_MENU)
TITLE:=Parallel port and line printer support