summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-04-01 08:31:33 +0000
committerJohn Crispin <john@openwrt.org>2015-04-01 08:31:33 +0000
commit66c742b6217f84bd0b09eba741f508f070de1b43 (patch)
treecf6a9951f00fe749999b3be0ab5003d30b759c50 /package/kernel/linux/modules/other.mk
parente078fbdacf120eb8da0bc7e4d1f8f90849c7f1d2 (diff)
downloadmaster-31e0f0ae-66c742b6217f84bd0b09eba741f508f070de1b43.tar.gz
master-31e0f0ae-66c742b6217f84bd0b09eba741f508f070de1b43.tar.bz2
master-31e0f0ae-66c742b6217f84bd0b09eba741f508f070de1b43.zip
modules: package line echo canceller module
...so we can go ahead cleaning up dahdi-linux Signed-off-by: Daniel Golle <daniel@makrotopia.org> SVN-Revision: 45206
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 6a5825011c..20964f5287 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -963,3 +963,19 @@ define KernelPackage/gpio-beeper/description
endef
$(eval $(call KernelPackage,gpio-beeper))
+
+
+define KernelPackage/echo
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Line Echo Canceller
+ KCONFIG:=CONFIG_ECHO
+ FILES:=$(LINUX_DIR)/drivers/misc/echo/echo.ko
+ AUTOLOAD:=$(call AutoLoad,50,echo)
+endef
+
+define KernelPackage/echo/description
+ This driver provides line echo cancelling support for mISDN and
+ DAHDI drivers
+endef
+
+$(eval $(call KernelPackage,echo))