summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-04-02 14:32:07 +0000
committerJohn Crispin <john@openwrt.org>2015-04-02 14:32:07 +0000
commit2bd178c175bb4173e8745149326ccad8f8cb1f25 (patch)
treefcead354a36c6aa0cfceae36b0c11dcc467cf85e /package/kernel/linux/modules/other.mk
parenta1b1be473e8854ad9f734bba191e17e71989c13a (diff)
downloadmaster-31e0f0ae-2bd178c175bb4173e8745149326ccad8f8cb1f25.tar.gz
master-31e0f0ae-2bd178c175bb4173e8745149326ccad8f8cb1f25.tar.bz2
master-31e0f0ae-2bd178c175bb4173e8745149326ccad8f8cb1f25.zip
kernel: watchdog modules should be loaded on boot
Otherwise procd cannot initialize the watchdog since the module will be loaded later. Tested with booke_wdt. Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com> SVN-Revision: 45239
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 20964f5287..36d3ef9e96 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -468,7 +468,7 @@ define KernelPackage/wdt-omap
DEPENDS:=@(TARGET_omap24xx||TARGET_omap35xx)
KCONFIG:=CONFIG_OMAP_WATCHDOG
FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/omap_wdt.ko
- AUTOLOAD:=$(call AutoLoad,50,omap_wdt.ko)
+ AUTOLOAD:=$(call AutoLoad,50,omap_wdt.ko,1)
endef
define KernelPackage/wdt-omap/description
@@ -484,7 +484,7 @@ define KernelPackage/wdt-orion
DEPENDS:=@TARGET_orion||TARGET_kirkwood||TARGET_mvebu
KCONFIG:=CONFIG_ORION_WATCHDOG
FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/orion_wdt.ko
- AUTOLOAD:=$(call AutoLoad,50,orion_wdt)
+ AUTOLOAD:=$(call AutoLoad,50,orion_wdt,1)
endef
define KernelPackage/wdt-orion/description
@@ -500,7 +500,7 @@ define KernelPackage/booke-wdt
DEPENDS:=@(TARGET_mpc85xx||TARGET_ppc40x||TARGET_ppc44x)
KCONFIG:=CONFIG_BOOKE_WDT
FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/booke_wdt.ko
- AUTOLOAD:=$(call AutoLoad,50,booke_wdt)
+ AUTOLOAD:=$(call AutoLoad,50,booke_wdt,1)
endef
define KernelPackage/booke-wdt/description