summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netsupport.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2016-01-19 15:14:51 +0000
committerFelix Fietkau <nbd@openwrt.org>2016-01-19 15:14:51 +0000
commite34acd64f5da8288bd0dab90265cfe96d21fe01f (patch)
treee6dbb747787ce9c26b29fe9991a3a33c818710bf /package/kernel/linux/modules/netsupport.mk
parent89ca7c5d0ed1da6fb4feb5973e5cb21d335dd36c (diff)
downloadmaster-31e0f0ae-e34acd64f5da8288bd0dab90265cfe96d21fe01f.tar.gz
master-31e0f0ae-e34acd64f5da8288bd0dab90265cfe96d21fe01f.tar.bz2
master-31e0f0ae-e34acd64f5da8288bd0dab90265cfe96d21fe01f.zip
kernel: disable AFS support by default
This pulls in CONFIG_KEYS, which bloats up the kernel size and is thus very undesirable. It also currently exposes the kernel to a local root vulnerability Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 48364
Diffstat (limited to 'package/kernel/linux/modules/netsupport.mk')
-rw-r--r--package/kernel/linux/modules/netsupport.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index e3fa9d7b5a..b1cce0b2d2 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -968,6 +968,7 @@ $(eval $(call KernelPackage,dnsresolver))
define KernelPackage/rxrpc
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=AF_RXRPC support
+ HIDDEN:=1
KCONFIG:= \
CONFIG_AF_RXRPC \
CONFIG_RXKAD=m \