summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netsupport.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-09-08 12:31:04 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-09-08 12:31:04 +0000
commite29efa2fb75c2bbe70f5f4027973eab5660db9cc (patch)
tree8528734f3345b9433a8410b95b799f3f7a3a3d2b /package/kernel/linux/modules/netsupport.mk
parent1b91cd2663b95c47942448222e74e22176466457 (diff)
downloadmaster-31e0f0ae-e29efa2fb75c2bbe70f5f4027973eab5660db9cc.tar.gz
master-31e0f0ae-e29efa2fb75c2bbe70f5f4027973eab5660db9cc.tar.bz2
master-31e0f0ae-e29efa2fb75c2bbe70f5f4027973eab5660db9cc.zip
kernel: remove packaging of kmod-crypto-core and kmod-crypto-arc4
Everything except for blkcipher was already built-in, so make blkcipher built-in as well. Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 46820
Diffstat (limited to 'package/kernel/linux/modules/netsupport.mk')
-rw-r--r--package/kernel/linux/modules/netsupport.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index adfdace360..333237f44b 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -713,7 +713,7 @@ $(eval $(call KernelPackage,ipoa))
define KernelPackage/mppe
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=Microsoft PPP compression/encryption
- DEPENDS:=kmod-ppp +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-sha1 +kmod-crypto-ecb
+ DEPENDS:=kmod-ppp +kmod-crypto-sha1 +kmod-crypto-ecb
KCONFIG:= \
CONFIG_PPP_MPPE_MPPC \
CONFIG_PPP_MPPE
@@ -997,7 +997,7 @@ define KernelPackage/rxrpc
$(LINUX_DIR)/net/rxrpc/af-rxrpc.ko \
$(LINUX_DIR)/net/rxrpc/rxkad.ko
AUTOLOAD:=$(call AutoLoad,30,rxkad af-rxrpc)
- DEPENDS:=+kmod-crypto-core +kmod-crypto-manager +kmod-crypto-pcbc +kmod-crypto-fcrypt
+ DEPENDS:= +kmod-crypto-manager +kmod-crypto-pcbc +kmod-crypto-fcrypt
endef
define KernelPackage/rxrpc/description