summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netfilter.mk
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2015-09-21 21:15:41 +0000
committerSteven Barth <cyrus@openwrt.org>2015-09-21 21:15:41 +0000
commit836d462b10e82a3314e62bb5d15a1632e5786271 (patch)
tree2ac6498c365f19c140284d2f9bb9978f8fab5bd2 /package/kernel/linux/modules/netfilter.mk
parentce59fe6b3d7ec186a12cf784038cc192a8eb9d4f (diff)
downloadmaster-31e0f0ae-836d462b10e82a3314e62bb5d15a1632e5786271.tar.gz
master-31e0f0ae-836d462b10e82a3314e62bb5d15a1632e5786271.tar.bz2
master-31e0f0ae-836d462b10e82a3314e62bb5d15a1632e5786271.zip
package: Remove dependencies to kmod-ipv6
Since r46834, IPv6 support is builtin if selected. Therefor, dependencies on kmod-ipv6 can no longer be fulfilled, since it is not a module anymore. Signed-off-by: Arjen de Korte <arjen+openwrt@de-korte.org> SVN-Revision: 47022
Diffstat (limited to 'package/kernel/linux/modules/netfilter.mk')
-rw-r--r--package/kernel/linux/modules/netfilter.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 3a436ac0c5..e21895d417 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -80,7 +80,7 @@ define KernelPackage/nf-conntrack6
SUBMENU:=$(NF_MENU)
TITLE:=Netfilter IPv6 connection tracking
KCONFIG:=$(KCONFIG_NF_CONNTRACK6)
- DEPENDS:=+kmod-ipv6 +kmod-nf-conntrack
+ DEPENDS:=@IPV6 +kmod-nf-conntrack
FILES:=$(foreach mod,$(NF_CONNTRACK6-m),$(LINUX_DIR)/net/$(mod).ko)
AUTOLOAD:=$(call AutoProbe,$(notdir $(NF_CONNTRACK6-m)))
endef
@@ -454,7 +454,7 @@ $(eval $(call KernelPackage,ipt-led))
define KernelPackage/ipt-tproxy
TITLE:=Transparent proxying support
- DEPENDS+=+kmod-ipt-conntrack +IPV6:kmod-ipv6 +IPV6:kmod-ip6tables
+ DEPENDS+=+kmod-ipt-conntrack +IPV6:kmod-ip6tables
KCONFIG:= \
CONFIG_NETFILTER_TPROXY \
CONFIG_NETFILTER_XT_MATCH_SOCKET \
@@ -473,7 +473,7 @@ $(eval $(call KernelPackage,ipt-tproxy))
define KernelPackage/ipt-tee
TITLE:=TEE support
- DEPENDS:=+kmod-ipt-conntrack +IPV6:kmod-ipv6
+ DEPENDS:=+kmod-ipt-conntrack
KCONFIG:= \
CONFIG_NETFILTER_XT_TARGET_TEE
FILES:= \