summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/netfilter.mk
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2013-09-01 17:59:48 +0000
committerSteven Barth <cyrus@openwrt.org>2013-09-01 17:59:48 +0000
commit0a85c59040d6e053199962fe9127cc0d2d8febc3 (patch)
tree7ec8d32d10fe30056a402b5d4a1cd4a069435e35 /package/kernel/linux/modules/netfilter.mk
parent3e647ac9b6c432571c7969a6f25852443b6b2705 (diff)
downloadmaster-31e0f0ae-0a85c59040d6e053199962fe9127cc0d2d8febc3.tar.gz
master-31e0f0ae-0a85c59040d6e053199962fe9127cc0d2d8febc3.tar.bz2
master-31e0f0ae-0a85c59040d6e053199962fe9127cc0d2d8febc3.zip
netfilter: Add IPv6-NAT support for kernel and ipt Thanks to Berni, Adam Novak and Sedat Dilek for patches and inspiration
SVN-Revision: 37866
Diffstat (limited to 'package/kernel/linux/modules/netfilter.mk')
-rw-r--r--package/kernel/linux/modules/netfilter.mk19
1 files changed, 18 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 496a9f9d4d..f657bad4c5 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -165,6 +165,23 @@ endef
$(eval $(call KernelPackage,ipt-nat))
+define KernelPackage/ipt-nat6
+ TITLE:=IPv6 NAT targets
+ KCONFIG:=$(KCONFIG_IPT_NAT6)
+ FILES:=$(foreach mod,$(IPT_NAT6-m),$(LINUX_DIR)/net/$(mod).ko)
+ AUTOLOAD:=$(call AutoLoad,43,$(notdir $(IPT_NAT6-m)))
+ $(call AddDepends/ipt,+kmod-ipt-conntrack)
+ $(call AddDepends/ipt,+kmod-ipt-nat)
+ $(call AddDepends/ipt,+kmod-ip6tables)
+endef
+
+define KernelPackage/ipt-nat6/description
+ Netfilter (IPv6) kernel modules for NAT targets
+endef
+
+$(eval $(call KernelPackage,ipt-nat6))
+
+
define KernelPackage/ipt-nat-extra
TITLE:=Extra NAT targets
KCONFIG:=$(KCONFIG_IPT_NAT_EXTRA)
@@ -394,7 +411,7 @@ define KernelPackage/ip6tables
DEPENDS:=+kmod-ipv6 +kmod-ipt-core +kmod-ipt-conntrack
KCONFIG:=$(KCONFIG_IPT_IPV6)
FILES:=$(foreach mod,$(IPT_IPV6-m),$(LINUX_DIR)/net/$(mod).ko)
- AUTOLOAD:=$(call AutoLoad,49,$(notdir $(IPT_IPV6-m)))
+ AUTOLOAD:=$(call AutoLoad,42,$(notdir $(IPT_IPV6-m)))
endef
define KernelPackage/ip6tables/description