summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/lib.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-07-18 13:08:33 +0000
committerJonas Gorski <jogo@openwrt.org>2013-07-18 13:08:33 +0000
commiteaadc5c4f97b91f76d2481b03102e68c8ef3c744 (patch)
treedf0b2a35fa27113132b6752bd5b10e69054a3063 /package/kernel/linux/modules/lib.mk
parent050061a565c78bbc2017d2930faec602db2828fe (diff)
downloadmaster-31e0f0ae-eaadc5c4f97b91f76d2481b03102e68c8ef3c744.tar.gz
master-31e0f0ae-eaadc5c4f97b91f76d2481b03102e68c8ef3c744.tar.bz2
master-31e0f0ae-eaadc5c4f97b91f76d2481b03102e68c8ef3c744.zip
kernel: move xor into its own package
xor.ko is needed by btrfs in 3.10+, so split it out into its own package. Make it hidden as it does not provide any functionality on its own. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 37395
Diffstat (limited to 'package/kernel/linux/modules/lib.mk')
-rw-r--r--package/kernel/linux/modules/lib.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/lib.mk b/package/kernel/linux/modules/lib.mk
index 095edb1a58..39a928a02b 100644
--- a/package/kernel/linux/modules/lib.mk
+++ b/package/kernel/linux/modules/lib.mk
@@ -133,6 +133,22 @@ endef
$(eval $(call KernelPackage,lib-raid6))
+define KernelPackage/lib-xor
+ SUBMENU:=$(LIB_MENU)
+ TITLE:=XOR blocks algorithm support
+ HIDDEN:=1
+ KCONFIG:=CONFIG_XOR_BLOCKS
+ FILES:=$(LINUX_DIR)/crypto/xor.ko
+ AUTOLOAD:=$(call AutoLoad,20,xor,1)
+endef
+
+define KernelPackage/lib-xor/description
+ Kernel module for XOR blocks algorithms.
+endef
+
+$(eval $(call KernelPackage,lib-xor))
+
+
define KernelPackage/lib-textsearch
SUBMENU:=$(LIB_MENU)
TITLE:=Textsearch support