summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/lib.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-10-08 15:08:33 +0000
committerJohn Crispin <john@openwrt.org>2013-10-08 15:08:33 +0000
commit925f37a5a6e2c6b201b650c50147879c41cc0f2c (patch)
tree3aff1d96c43900f5d351eab30c71b44b743a26c0 /package/kernel/linux/modules/lib.mk
parent4b47d5b73205ef70614d62a81c4c0b6816b7802f (diff)
downloadmaster-31e0f0ae-925f37a5a6e2c6b201b650c50147879c41cc0f2c.tar.gz
master-31e0f0ae-925f37a5a6e2c6b201b650c50147879c41cc0f2c.tar.bz2
master-31e0f0ae-925f37a5a6e2c6b201b650c50147879c41cc0f2c.zip
kernel: dont rely on library modules to be depended on
fixes https://dev.openwrt.org/ticket/14257 Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 38341
Diffstat (limited to 'package/kernel/linux/modules/lib.mk')
-rw-r--r--package/kernel/linux/modules/lib.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/lib.mk b/package/kernel/linux/modules/lib.mk
index 02d6cfbae2..af536270f6 100644
--- a/package/kernel/linux/modules/lib.mk
+++ b/package/kernel/linux/modules/lib.mk
@@ -12,6 +12,7 @@ define KernelPackage/lib-crc-ccitt
TITLE:=CRC-CCITT support
KCONFIG:=CONFIG_CRC_CCITT
FILES:=$(LINUX_DIR)/lib/crc-ccitt.ko
+ AUTOLOAD:=$(call AutoProbe,crc-ccitt)
endef
define KernelPackage/lib-crc-ccitt/description
@@ -26,6 +27,7 @@ define KernelPackage/lib-crc-itu-t
TITLE:=CRC ITU-T V.41 support
KCONFIG:=CONFIG_CRC_ITU_T
FILES:=$(LINUX_DIR)/lib/crc-itu-t.ko
+ AUTOLOAD:=$(call AutoProbe,crc-itu-t)
endef
define KernelPackage/lib-crc-itu-t/description
@@ -40,6 +42,7 @@ define KernelPackage/lib-crc7
TITLE:=CRC7 support
KCONFIG:=CONFIG_CRC7
FILES:=$(LINUX_DIR)/lib/crc7.ko
+ AUTOLOAD:=$(call AutoProbe,crc7)
endef
define KernelPackage/lib-crc7/description
@@ -54,6 +57,7 @@ define KernelPackage/lib-crc8
TITLE:=CRC8 support
KCONFIG:=CONFIG_CRC8
FILES:=$(LINUX_DIR)/lib/crc8.ko
+ AUTOLOAD:=$(call AutoProbe,crc8)
endef
define KernelPackage/lib-crc8/description
@@ -68,6 +72,7 @@ define KernelPackage/lib-crc16
TITLE:=CRC16 support
KCONFIG:=CONFIG_CRC16
FILES:=$(LINUX_DIR)/lib/crc16.ko
+ AUTOLOAD:=$(call AutoProbe,crc16)
endef
define KernelPackage/lib-crc16/description
@@ -83,6 +88,7 @@ define KernelPackage/lib-crc32c
KCONFIG:=CONFIG_LIBCRC32C
DEPENDS:=+kmod-crypto-crc32c
FILES:=$(LINUX_DIR)/lib/libcrc32c.ko
+ AUTOLOAD:=$(call AutoProbe,libcrc32c)
endef
define KernelPackage/lib-crc32c/description
@@ -101,6 +107,7 @@ define KernelPackage/lib-lzo
FILES:= \
$(LINUX_DIR)/lib/lzo/lzo_compress.ko \
$(LINUX_DIR)/lib/lzo/lzo_decompress.ko
+ AUTOLOAD:=$(call AutoProbe,lzo_compress lzo_decompress)
endef
define KernelPackage/lib-lzo/description
@@ -116,6 +123,7 @@ define KernelPackage/lib-raid6
HIDDEN:=1
KCONFIG:=CONFIG_RAID6_PQ
FILES:=$(LINUX_DIR)/lib/raid6/raid6_pq.ko
+ AUTOLOAD:=$(call AutoProbe,raid6_pq)
endef
define KernelPackage/lib-raid6/description
@@ -131,6 +139,7 @@ define KernelPackage/lib-xor
HIDDEN:=1
KCONFIG:=CONFIG_XOR_BLOCKS
FILES:=$(LINUX_DIR)/crypto/xor.ko
+ AUTOLOAD:=$(call AutoProbe,xor)
endef
define KernelPackage/lib-xor/description
@@ -167,6 +176,7 @@ define KernelPackage/lib-zlib
FILES:= \
$(LINUX_DIR)/lib/zlib_deflate/zlib_deflate.ko \
$(LINUX_DIR)/lib/zlib_inflate/zlib_inflate.ko
+ AUTOLOAD:=$(call AutoProbe,zlib_deflate zlib_inflate)
endef
$(eval $(call KernelPackage,lib-zlib))
@@ -177,6 +187,7 @@ define KernelPackage/lib-cordic
TITLE:=Cordic function support
KCONFIG:=CONFIG_CORDIC
FILES:=$(LINUX_DIR)/lib/cordic.ko
+ AUTOLOAD:=$(call AutoProbe,cordic)
endef
define KernelPackage/lib-cordic/description