summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/leds.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2016-02-09 12:33:53 +0000
committerJo-Philipp Wich <jow@openwrt.org>2016-02-09 12:33:53 +0000
commit2d04407e404183f72901b4fdb53c4625518b0bd9 (patch)
tree78d97eb2334ca9a3e229fac79ff524c2883394cc /package/kernel/linux/modules/leds.mk
parent791076dae83449359286841127ab5a16818892b3 (diff)
downloadmaster-31e0f0ae-2d04407e404183f72901b4fdb53c4625518b0bd9.tar.gz
master-31e0f0ae-2d04407e404183f72901b4fdb53c4625518b0bd9.tar.bz2
master-31e0f0ae-2d04407e404183f72901b4fdb53c4625518b0bd9.zip
mvebu: fix WRT1900AC v1 LED driver module
Update OpenWRT build tree to reflect changes in TLC-591xx LED family driver. In kernels < 4.0 the driver was present in form of a patch for the TLC-59116 chip, and was upstreamed later in kernels > 4.0 to support the entire chip family. Signed-off-by: Sebastian Careba <nitroshift@yahoo.com> [jow: fix Kconfig symbol name] Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 48684
Diffstat (limited to 'package/kernel/linux/modules/leds.mk')
-rw-r--r--package/kernel/linux/modules/leds.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/package/kernel/linux/modules/leds.mk b/package/kernel/linux/modules/leds.mk
index 996deb3790..c4261d31ac 100644
--- a/package/kernel/linux/modules/leds.mk
+++ b/package/kernel/linux/modules/leds.mk
@@ -199,17 +199,17 @@ endef
$(eval $(call KernelPackage,leds-pca963x))
-define KernelPackage/leds-tlc59116
+define KernelPackage/leds-tlc591xx
SUBMENU:=$(LEDS_MENU)
- TITLE:=TLC59116 LED support
+ TITLE:=TLC591xx LED support
DEPENDS:=@TARGET_mvebu +kmod-i2c-core +kmod-regmap
- KCONFIG:=CONFIG_LEDS_TLC59116
- FILES:=$(LINUX_DIR)/drivers/leds/leds-tlc59116.ko
- AUTOLOAD:=$(call AutoLoad,60,leds-tlc59116,1)
+ KCONFIG:=CONFIG_LEDS_TLC591XX
+ FILES:=$(LINUX_DIR)/drivers/leds/leds-tlc591xx.ko
+ AUTOLOAD:=$(call AutoLoad,60,leds-tlc591xx,1)
endef
-define KernelPackage/leds-tlc59116/description
- Kernel module for LEDs on TLC59116
+define KernelPackage/leds-tlc591xx/description
+ Kernel module for LEDs on TLC591xx
endef
-$(eval $(call KernelPackage,leds-tlc59116))
+$(eval $(call KernelPackage,leds-tlc591xx))