summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/input.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-07-14 17:23:56 +0000
committerJo-Philipp Wich <jow@openwrt.org>2015-07-14 17:23:56 +0000
commit52bfee77e47fab1ca2a6be8712b00619bccc2d13 (patch)
treed0ddde8c0019d7e559f7b815a7dcccbc9fc01936 /package/kernel/linux/modules/input.mk
parent94ef06a8c2e9b6b82d7a2af96b19b1247d088dc7 (diff)
downloadmaster-31e0f0ae-52bfee77e47fab1ca2a6be8712b00619bccc2d13.tar.gz
master-31e0f0ae-52bfee77e47fab1ca2a6be8712b00619bccc2d13.tar.bz2
master-31e0f0ae-52bfee77e47fab1ca2a6be8712b00619bccc2d13.zip
linux: enable kmod-acpi-button for x86_64 (#20080)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 46368
Diffstat (limited to 'package/kernel/linux/modules/input.mk')
-rw-r--r--package/kernel/linux/modules/input.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 86ff33cb26..0539493cbd 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -176,7 +176,7 @@ $(eval $(call KernelPackage,input-matrixkmap))
define KernelPackage/acpi-button
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=ACPI Button Support
- DEPENDS:=@(TARGET_x86_generic||TARGET_x86_kvm_guest||TARGET_x86_xen_domu) +kmod-input-evdev
+ DEPENDS:=@(TARGET_x86_generic||TARGET_x86_kvm_guest||TARGET_x86_xen_domu||TARGET_x86_64) +kmod-input-evdev
KCONFIG:=CONFIG_ACPI_BUTTON
FILES:=$(LINUX_DIR)/drivers/acpi/button.ko
AUTOLOAD:=$(call AutoLoad,06,button)