summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/input.mk
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-10-25 10:29:49 +0000
committerLuka Perkov <luka@openwrt.org>2013-10-25 10:29:49 +0000
commit3d77352390cb3d8081d6cfbde14444a39aa77a0a (patch)
tree65475e1d4293bbdfe71d569a72e35c2d81eb989c /package/kernel/linux/modules/input.mk
parent61a4b9753d61495e7e34b91d18ec1bc68adae750 (diff)
downloadmaster-31e0f0ae-3d77352390cb3d8081d6cfbde14444a39aa77a0a.tar.gz
master-31e0f0ae-3d77352390cb3d8081d6cfbde14444a39aa77a0a.tar.bz2
master-31e0f0ae-3d77352390cb3d8081d6cfbde14444a39aa77a0a.zip
kernel: add keyboard-imx module
Signed-off-by: Luka Perkov <luka@openwrt.org> SVN-Revision: 38537
Diffstat (limited to 'package/kernel/linux/modules/input.mk')
-rw-r--r--package/kernel/linux/modules/input.mk20
1 files changed, 19 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 421a6b8fca..32adc1ecf4 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -159,7 +159,7 @@ define KernelPackage/input-matrixkmap
KCONFIG:=CONFIG_INPUT_MATRIXKMAP
DEPENDS:=@!LINUX_3_3
FILES:=$(LINUX_DIR)/drivers/input/matrix-keymap.ko
- AUTOLOAD:=$(call AutoLoad,20,matrix-keymap)
+ AUTOLOAD:=$(call AutoProbe,matrix-keymap)
$(call AddDepends/input)
endef
@@ -184,3 +184,21 @@ define KernelPackage/acpi-button/description
endef
$(eval $(call KernelPackage,acpi-button))
+
+
+define KernelPackage/keyboard-imx
+ SUBMENU:=$(INPUT_MODULES_MENU)
+ TITLE:=IMX keypad support
+ DEPENDS:=@(TARGET_mxs||TARGET_imx6) +kmod-input-matrixkmap
+ KCONFIG:= \
+ CONFIG_KEYBOARD_IMX \
+ CONFIG_INPUT_KEYBOARD=y
+ FILES:=$(LINUX_DIR)/drivers/input/keyboard/imx_keypad.ko
+ AUTOLOAD:=$(call AutoProbe,imx_keypad)
+endef
+
+define KernelPackage/keyboard-imx/description
+ Enable support for IMX keypad port.
+endef
+
+$(eval $(call KernelPackage,keyboard-imx))