summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/input.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-07-19 13:20:41 +0000
committerJonas Gorski <jogo@openwrt.org>2013-07-19 13:20:41 +0000
commit29954b9ffcb0022101e70d6a73d090e868e624d7 (patch)
treec9feb47d7c6e14039beff4c7648c90d8a2630adf /package/kernel/linux/modules/input.mk
parent960002ed4b148cffa7e2562ff4536d3708342765 (diff)
downloadmaster-31e0f0ae-29954b9ffcb0022101e70d6a73d090e868e624d7.tar.gz
master-31e0f0ae-29954b9ffcb0022101e70d6a73d090e868e624d7.tar.bz2
master-31e0f0ae-29954b9ffcb0022101e70d6a73d090e868e624d7.zip
kernel: remove gpio_buttons
It hasn't been buildable for a long time, and there are no users of it anymore left as all of them have been switched to the upstream accepted version. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 37436
Diffstat (limited to 'package/kernel/linux/modules/input.mk')
-rw-r--r--package/kernel/linux/modules/input.mk18
1 files changed, 0 insertions, 18 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 78fa9241cd..f0bc7bd0ad 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -68,24 +68,6 @@ endef
$(eval $(call KernelPackage,input-evdev))
-define KernelPackage/input-gpio-buttons
- SUBMENU:=$(INPUT_MODULES_MENU)
- TITLE:=Polled GPIO buttons input device
- DEPENDS:=@GPIO_SUPPORT +kmod-input-polldev
- KCONFIG:= \
- CONFIG_INPUT_GPIO_BUTTONS \
- CONFIG_INPUT_MISC=y
- FILES:=$(LINUX_DIR)/drivers/input/misc/gpio_buttons.ko
- AUTOLOAD:=$(call AutoLoad,62,gpio_buttons,1)
-endef
-
-define KernelPackage/input-gpio-buttons/description
- Kernel module for support polled GPIO buttons input device
-endef
-
-$(eval $(call KernelPackage,input-gpio-buttons))
-
-
define KernelPackage/input-gpio-keys
SUBMENU:=$(INPUT_MODULES_MENU)
TITLE:=GPIO key support