summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/input.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-01-17 07:07:28 +0000
committerJohn Crispin <john@openwrt.org>2015-01-17 07:07:28 +0000
commit03a708a0dbce4c63bb200661e1641f0f01f99e8d (patch)
tree6d1423f898fdfaa2f76eed90d2e3a594bd422208 /package/kernel/linux/modules/input.mk
parent8cbf97e936f8e7956138e5078361a35594c99e43 (diff)
downloadmaster-31e0f0ae-03a708a0dbce4c63bb200661e1641f0f01f99e8d.tar.gz
master-31e0f0ae-03a708a0dbce4c63bb200661e1641f0f01f99e8d.tar.bz2
master-31e0f0ae-03a708a0dbce4c63bb200661e1641f0f01f99e8d.zip
kernel: add references to openwrt alternative button handling
Add documentation that makes it easier to find the alternative, recommended, and default handling for buttons in OpenWrt. Signed-off-by: Karl Palsson <karlp@tweak.net.au> SVN-Revision: 43989
Diffstat (limited to 'package/kernel/linux/modules/input.mk')
-rw-r--r--package/kernel/linux/modules/input.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 32adc1ecf4..f42cbaec06 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -82,6 +82,9 @@ endef
define KernelPackage/input-gpio-keys/description
This driver implements support for buttons connected
to GPIO pins of various CPUs (and some other chips).
+
+ See also gpio-button-hotplug which is an alternative, lower overhead
+ implementation that generates uevents instead of kernel input events.
endef
$(eval $(call KernelPackage,input-gpio-keys))
@@ -101,6 +104,9 @@ endef
define KernelPackage/input-gpio-keys-polled/description
Kernel module for support polled GPIO keys input device
+
+ See also gpio-button-hotplug which is an alternative, lower overhead
+ implementation that generates uevents instead of kernel input events.
endef
$(eval $(call KernelPackage,input-gpio-keys-polled))