summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/input.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-04-02 14:31:02 +0000
committerJohn Crispin <john@openwrt.org>2015-04-02 14:31:02 +0000
commit023a05fe7a2f9f4a90ef385a7366655d3aa26b9e (patch)
tree981c0ecf7057ffa79985f7b0cde196cffd17ac55 /package/kernel/linux/modules/input.mk
parent509cce44bd66f43061afb5154538239f8552c069 (diff)
downloadmaster-31e0f0ae-023a05fe7a2f9f4a90ef385a7366655d3aa26b9e.tar.gz
master-31e0f0ae-023a05fe7a2f9f4a90ef385a7366655d3aa26b9e.tar.bz2
master-31e0f0ae-023a05fe7a2f9f4a90ef385a7366655d3aa26b9e.zip
kernel: add uinput module
This module is needed for bluetooth audio playback with pulseaudio 6 and bluez5. a working guide can be found in the wiki: http://wiki.openwrt.org/wiki/bluetooth.audio (additional packages/modifications are required and submitted to github feeds) tested with: Android mobile (Sony Xperia M) as audio source TI omap BeagleBoard as audio sink Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> SVN-Revision: 45231
Diffstat (limited to 'package/kernel/linux/modules/input.mk')
-rw-r--r--package/kernel/linux/modules/input.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index b44136b78c..86ff33cb26 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -205,3 +205,21 @@ define KernelPackage/keyboard-imx/description
endef
$(eval $(call KernelPackage,keyboard-imx))
+
+
+define KernelPackage/input-uinput
+ SUBMENU:=$(INPUT_MODULES_MENU)
+ TITLE:=user input module
+ DEPENDS:=+kmod-input-core
+ KCONFIG:= \
+ CONFIG_INPUT_MISC=y \
+ CONFIG_INPUT_UINPUT
+ FILES:=$(LINUX_DIR)/drivers/input/misc/uinput.ko
+ AUTOLOAD:=$(call AutoProbe,uinput)
+endef
+
+define KernelPackage/input-uinput/description
+ user input modules needed for bluez
+endef
+
+$(eval $(call KernelPackage,input-uinput))