summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/i2c.mk
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-25 18:00:33 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-25 18:00:33 +0000
commit6ac0dfb2803a77b19acd98a73f8991f23f846f76 (patch)
treec568478dbd3872bdeb6b4eef3b69feae480ff2fc /package/kernel/linux/modules/i2c.mk
parentcbcd3024dce4c7df45f5374be0ed534bcbeb1fd4 (diff)
downloadmaster-31e0f0ae-6ac0dfb2803a77b19acd98a73f8991f23f846f76.tar.gz
master-31e0f0ae-6ac0dfb2803a77b19acd98a73f8991f23f846f76.tar.bz2
master-31e0f0ae-6ac0dfb2803a77b19acd98a73f8991f23f846f76.zip
package/kernel: move I2C-GPIO drivers from i2c.mk to other.mk
Move pca953x support from i2c.mk to other.mk, where other GPIO drivers are located. Remove duplicate pcf857x support from i2c.mk. Signed-off-by: Hartmut Knaack <knaack.h@gmx.de> [juhosg: update subject, and reformat commit message] Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38185
Diffstat (limited to 'package/kernel/linux/modules/i2c.mk')
-rw-r--r--package/kernel/linux/modules/i2c.mk31
1 files changed, 0 insertions, 31 deletions
diff --git a/package/kernel/linux/modules/i2c.mk b/package/kernel/linux/modules/i2c.mk
index f1eea31807..8a26f42e75 100644
--- a/package/kernel/linux/modules/i2c.mk
+++ b/package/kernel/linux/modules/i2c.mk
@@ -237,34 +237,3 @@ define KernelPackage/i2c-mux-pca9541/description
endef
$(eval $(call KernelPackage,i2c-mux-pca9541))
-
-GPIO_PCA953X_MODULES:= \
- CONFIG_GPIO_PCA953X:drivers/gpio/gpio-pca953x
-
-define KernelPackage/pca953x
- $(call i2c_defaults,$(GPIO_PCA953X_MODULES),51)
- TITLE:=Philips PCA953x I2C GPIO extenders
- DEPENDS:=kmod-i2c-core
-endef
-
-define KernelPackage/pca953x/description
- Kernel modules for PCA953x I2C GPIO extenders
-endef
-
-$(eval $(call KernelPackage,pca953x))
-
-
-GPIO_PCF857X_MODULES:= \
- CONFIG_GPIO_PCF857X:drivers/gpio/gpio-pcf857x
-
-define KernelPackage/pcf857x
- $(call i2c_defaults,$(GPIO_PCF857X_MODULES),51)
- TITLE:=Philips PCF857x I2C GPIO extenders
- DEPENDS:=kmod-i2c-core
-endef
-
-define KernelPackage/pcf857x/description
- Kernel modules for PCF857x I2C GPIO extenders
-endef
-
-$(eval $(call KernelPackage,pcf857x))