summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/i2c.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-24 22:13:22 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-24 22:13:22 +0000
commit47e651e2ebd313a75130c9e7746f7b2f501488b4 (patch)
tree8f57bcc4e7c784e93b72e7cd9139ceeb6c9c3d69 /package/kernel/linux/modules/i2c.mk
parent77aa8e8aee1563ac90feb40aec277da6e0ecc139 (diff)
downloadmaster-31e0f0ae-47e651e2ebd313a75130c9e7746f7b2f501488b4.tar.gz
master-31e0f0ae-47e651e2ebd313a75130c9e7746f7b2f501488b4.tar.bz2
master-31e0f0ae-47e651e2ebd313a75130c9e7746f7b2f501488b4.zip
kernel: drop obsolete kernel version checks
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 44113
Diffstat (limited to 'package/kernel/linux/modules/i2c.mk')
-rw-r--r--package/kernel/linux/modules/i2c.mk11
1 files changed, 1 insertions, 10 deletions
diff --git a/package/kernel/linux/modules/i2c.mk b/package/kernel/linux/modules/i2c.mk
index 7643138064..a2dcf35e53 100644
--- a/package/kernel/linux/modules/i2c.mk
+++ b/package/kernel/linux/modules/i2c.mk
@@ -206,13 +206,8 @@ endef
$(eval $(call KernelPackage,i2c-mux))
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.6.0)),1)
I2C_MUX_GPIO_MODULES:= \
CONFIG_I2C_MUX_GPIO:drivers/i2c/muxes/i2c-mux-gpio
-else
-I2C_MUX_GPIO_MODULES:= \
- CONFIG_I2C_MUX_GPIO:drivers/i2c/muxes/gpio-i2cmux
-endif
define KernelPackage/i2c-mux-gpio
$(call i2c_defaults,$(I2C_MUX_GPIO_MODULES),51)
@@ -226,12 +221,8 @@ endef
$(eval $(call KernelPackage,i2c-mux-gpio))
-ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.6.0)),1)
-I2C_MUX_PREFIX:=i2c-mux-
-endif
-
I2C_MUX_PCA954x_MODULES:= \
- CONFIG_I2C_MUX_PCA954x:drivers/i2c/muxes/$(I2C_MUX_PREFIX)pca954x
+ CONFIG_I2C_MUX_PCA954x:drivers/i2c/muxes/i2c-mux-pca954x
define KernelPackage/i2c-mux-pca954x
$(call i2c_defaults,$(I2C_MUX_PCA954x_MODULES),51)