summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/hwmon.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2014-09-14 12:06:38 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2014-09-14 12:06:38 +0000
commitf734314484567c97f483a1971e39c3e6d78e4427 (patch)
tree25b5475efc114b164132f9bf60940e27df5e553a /package/kernel/linux/modules/hwmon.mk
parent6ea49c5e135e8700ac342c4b5fb1fa5cc460f74c (diff)
downloadmaster-31e0f0ae-f734314484567c97f483a1971e39c3e6d78e4427.tar.gz
master-31e0f0ae-f734314484567c97f483a1971e39c3e6d78e4427.tar.bz2
master-31e0f0ae-f734314484567c97f483a1971e39c3e6d78e4427.zip
kernel: make hwmon-lm75 only depend on kmod-thermal if needed
This fixes commit r42529 and closes #17855. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 42531
Diffstat (limited to 'package/kernel/linux/modules/hwmon.mk')
-rw-r--r--package/kernel/linux/modules/hwmon.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 90f2197aa9..ad0ef2dd4e 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -119,7 +119,7 @@ define KernelPackage/hwmon-lm75
KCONFIG:=CONFIG_SENSORS_LM75
FILES:=$(LINUX_DIR)/drivers/hwmon/lm75.ko
AUTOLOAD:=$(call AutoProbe,lm75)
- $(call AddDepends/hwmon,+kmod-i2c-core +kmod-thermal)
+ $(call AddDepends/hwmon,+kmod-i2c-core +PACKAGE_kmod-thermal:kmod-thermal)
endef
define KernelPackage/hwmon-lm75/description