summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/hwmon.mk
diff options
context:
space:
mode:
authorLuka Perkov <luka@openwrt.org>2013-09-10 22:26:30 +0000
committerLuka Perkov <luka@openwrt.org>2013-09-10 22:26:30 +0000
commit7d73153e86c9c139f34467c30bda3f7e498834a1 (patch)
tree5bbf09f1d209cb2513b4c3584ff064681a6e563a /package/kernel/linux/modules/hwmon.mk
parent35d2b601aa7737c5eebe8557bd4cb056e52b2f5d (diff)
downloadmaster-31e0f0ae-7d73153e86c9c139f34467c30bda3f7e498834a1.tar.gz
master-31e0f0ae-7d73153e86c9c139f34467c30bda3f7e498834a1.tar.bz2
master-31e0f0ae-7d73153e86c9c139f34467c30bda3f7e498834a1.zip
kernel: allow hwmon GSC driver for all targets
- enable using hwmon GSC driver on all targets - add a kmod package for it Signed-off-by: Tim Harvey <tharvey@gateworks.com> SVN-Revision: 37933
Diffstat (limited to 'package/kernel/linux/modules/hwmon.mk')
-rw-r--r--package/kernel/linux/modules/hwmon.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 5af311df66..b1f4744330 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -219,3 +219,18 @@ define KernelPacakge/hwmon-w83627hf/description
endef
$(eval $(call KernelPackage,hwmon-w83627hf))
+
+
+define KernelPackage/hwmon-gsc
+ TITLE:=Gateworks GSC monitoring support
+ KCONFIG:=CONFIG_SENSORS_GSC
+ FILES:=$(LINUX_DIR)/drivers/hwmon/gsc.ko
+ AUTOLOAD:=$(call AutoLoad,50,gsc)
+$(call AddDepends/hwmon)
+endef
+
+define KernelPacakge/hwmon-gsc/description
+ Kernel module for the Gateworks System Controller chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-gsc))