summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/hwmon.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-10-22 11:30:07 +0000
committerJo-Philipp Wich <jow@openwrt.org>2014-10-22 11:30:07 +0000
commit3df1a20197154d9e3ff65b5fe671a11a44ed08d2 (patch)
treef2ac5bf070180f4f209da700054d3e77ef28a55a /package/kernel/linux/modules/hwmon.mk
parenta1837135e04b511a6204937c8ed00ba637cc6f0f (diff)
downloadmaster-31e0f0ae-3df1a20197154d9e3ff65b5fe671a11a44ed08d2.tar.gz
master-31e0f0ae-3df1a20197154d9e3ff65b5fe671a11a44ed08d2.tar.bz2
master-31e0f0ae-3df1a20197154d9e3ff65b5fe671a11a44ed08d2.zip
linux: add kmod-hwmon-k10temp
This module is required to read the CPU core temperature sensors on the Alix APU board. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org> SVN-Revision: 43027
Diffstat (limited to 'package/kernel/linux/modules/hwmon.mk')
-rw-r--r--package/kernel/linux/modules/hwmon.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 301e06f6c2..5b7936a9f0 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -288,3 +288,19 @@ define KernelPackage/hwmon-gpiofan/description
endef
$(eval $(call KernelPackage,hwmon-gpiofan))
+
+
+define KernelPackage/hwmon-k10temp
+ TITLE:=AMD Family 10h+ temperature sensor
+ KCONFIG:=CONFIG_SENSORS_K10TEMP
+ FILES:=$(LINUX_DIR)/drivers/hwmon/k10temp.ko
+ AUTOLOAD:=$(call AutoLoad,60,k10temp)
+ $(call AddDepends/hwmon,@PCI_SUPPORT @(x86||x86_64))
+endef
+
+define KernelPackage/hwmon-k10temp/description
+ Thermal sensor support for AMD 10h, 11h, 12h (Llano), 14h (Brazos),
+ 15h (Bulldozer/Trinity/Kaveri) and 16h (Kabini/Mullins) CPUs
+endef
+
+$(eval $(call KernelPackage,hwmon-k10temp))