summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/hwmon.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-22 19:05:35 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-22 19:05:35 +0000
commit2be144fa3c867436918050e09273bff2507c8284 (patch)
tree22b82a602f517e6f556f7da82102cb86f09d9f86 /package/kernel/linux/modules/hwmon.mk
parent854c77bcea2ed4ebf3faebcc45acf9a82b0f72d8 (diff)
downloadmaster-31e0f0ae-2be144fa3c867436918050e09273bff2507c8284.tar.gz
master-31e0f0ae-2be144fa3c867436918050e09273bff2507c8284.tar.bz2
master-31e0f0ae-2be144fa3c867436918050e09273bff2507c8284.zip
kernel: make kmod-thermal dependency conditional to match upstream kernel module configuration dependency
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47961
Diffstat (limited to 'package/kernel/linux/modules/hwmon.mk')
-rw-r--r--package/kernel/linux/modules/hwmon.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index ad1c7bf91d..e09efa17c0 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -274,7 +274,7 @@ define KernelPackage/hwmon-gpiofan
KCONFIG:=CONFIG_SENSORS_GPIO_FAN
FILES:=$(LINUX_DIR)/drivers/hwmon/gpio-fan.ko
AUTOLOAD:=$(call AutoLoad,60,gpio-fan)
- $(call AddDepends/hwmon,+kmod-i2c-core +kmod-thermal)
+ $(call AddDepends/hwmon,+kmod-i2c-core +PACKAGE_kmod-thermal:kmod-thermal)
endef
define KernelPackage/hwmon-gpiofan/description