summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/hwmon.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-06-17 15:03:05 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-06-17 15:03:05 +0000
commit099d998fcf21c80e25a9518607285d1437d89be9 (patch)
tree8329783478d3d2c00727a4694b0139ea8f88f144 /package/kernel/linux/modules/hwmon.mk
parent60f1a7bd4bc46dece632c525446cbdef92292683 (diff)
downloadmaster-31e0f0ae-099d998fcf21c80e25a9518607285d1437d89be9.tar.gz
master-31e0f0ae-099d998fcf21c80e25a9518607285d1437d89be9.tar.bz2
master-31e0f0ae-099d998fcf21c80e25a9518607285d1437d89be9.zip
package the TI TMP421 driver
SVN-Revision: 41231
Diffstat (limited to 'package/kernel/linux/modules/hwmon.mk')
-rw-r--r--package/kernel/linux/modules/hwmon.mk16
1 files changed, 15 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 9dd47344de..7831f701a2 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2010 OpenWrt.org
+# Copyright (C) 2006-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -258,3 +258,17 @@ define KernelPacakge/hwmon-gsc/description
endef
$(eval $(call KernelPackage,hwmon-gsc))
+
+define KernelPackage/hwmon-tmp421
+ TITLE:=TI TMP421 and compatible monitoring support
+ KCONFIG:=CONFIG_SENSORS_TMP421
+ FILES:=$(LINUX_DIR)/drivers/hwmon/tmp421.ko
+ AUTOLOAD:=$(call AutoLoad,60,tmp421)
+ $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPacakge/hwmon-tmp421/description
+ Kernel module for the Texas Instruments TMP421 and compatible chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-tmp421))