summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-05 13:02:08 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-05 13:02:08 +0000
commitf51dc17eddff60d46009ca85c2ee50c46ca7d9df (patch)
tree20a137db8695c8b973db297fd76949d115d3ff22 /package/kernel/linux/modules/crypto.mk
parent5a1f38ad0ff7776f8f1c99326f093aafcc5224cc (diff)
downloadmaster-31e0f0ae-f51dc17eddff60d46009ca85c2ee50c46ca7d9df.tar.gz
master-31e0f0ae-f51dc17eddff60d46009ca85c2ee50c46ca7d9df.tar.bz2
master-31e0f0ae-f51dc17eddff60d46009ca85c2ee50c46ca7d9df.zip
kernel/modules: add kmod-crypto-ghash
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> SVN-Revision: 43837
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index eec7934f16..9d69cce9d5 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -411,6 +411,18 @@ endef
$(eval $(call KernelPackage,crypto-gf128))
+define KernelPackage/crypto-ghash
+ TITLE:=GHASH digest CryptoAPI module
+ DEPENDS:=+kmod-crypto-gf128
+ KCONFIG:=CONFIG_CRYPTO_GHASH
+ FILES:=$(LINUX_DIR)/crypto/ghash-generic.ko
+ AUTOLOAD:=$(call AutoLoad,09,ghash-generic)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-ghash))
+
+
define KernelPackage/crypto-md4
TITLE:=MD4 digest CryptoAPI module
DEPENDS:=+kmod-crypto-hash