summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-12 12:02:20 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-12 12:02:20 +0000
commitf0664d34a6abb7fccc685146d15827b6851da505 (patch)
treef599f275032ea794631e237f11043730c485efe4 /package/kernel/linux/modules/crypto.mk
parentbb52e2e1ef15c7b933f1d548ccee96536b21f84a (diff)
downloadmaster-31e0f0ae-f0664d34a6abb7fccc685146d15827b6851da505.tar.gz
master-31e0f0ae-f0664d34a6abb7fccc685146d15827b6851da505.tar.bz2
master-31e0f0ae-f0664d34a6abb7fccc685146d15827b6851da505.zip
kernel: make kmod-crypto-rng depend on kmod-crypto-hash
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47883
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index dc817eed5f..604be9fce9 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -100,6 +100,7 @@ $(eval $(call KernelPackage,crypto-wq))
define KernelPackage/crypto-rng
TITLE:=CryptoAPI random number generation
+ DEPENDS:=+kmod-crypto-hash
KCONFIG:= \
CONFIG_CRYPTO_DRBG \
CONFIG_CRYPTO_JITTERENTROPY \