summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-12-11 19:21:49 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-12-11 19:21:49 +0000
commit84a56a7849e807bf90ebed56e8617fbd82ef043d (patch)
tree2b7e11b88e151bb9d0fe7b89af69bff4bb1717a8 /package/kernel/linux/modules/crypto.mk
parentd437c72c216b45aa27187bbfddbf43fafdc0b5fe (diff)
downloadmaster-31e0f0ae-84a56a7849e807bf90ebed56e8617fbd82ef043d.tar.gz
master-31e0f0ae-84a56a7849e807bf90ebed56e8617fbd82ef043d.tar.bz2
master-31e0f0ae-84a56a7849e807bf90ebed56e8617fbd82ef043d.zip
kernel: crypto-aead depends on crypto-null in 4.3 as well
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 47870
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index fe64db46f7..dc817eed5f 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -27,7 +27,7 @@ define KernelPackage/crypto-aead
CONFIG_CRYPTO_AEAD2
FILES:=$(LINUX_DIR)/crypto/aead.ko
AUTOLOAD:=$(call AutoLoad,09,aead,1)
- $(call AddDepends/crypto, +LINUX_4_4:kmod-crypto-null)
+ $(call AddDepends/crypto, +LINUX_4_3:kmod-crypto-null +LINUX_4_4:kmod-crypto-null)
endef
$(eval $(call KernelPackage,crypto-aead))