summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2015-07-04 22:33:00 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2015-07-04 22:33:00 +0000
commit5e3c3d47885fd744d84ba3abf3cfc0d6a9ea4f6c (patch)
treea1c8ae60b91513ec8730a03a93c96f8306a407b9 /package/kernel/linux/modules/crypto.mk
parent3d10cd51d492b4511d4bcba5bd1d084b065ac4b9 (diff)
downloadmaster-31e0f0ae-5e3c3d47885fd744d84ba3abf3cfc0d6a9ea4f6c.tar.gz
master-31e0f0ae-5e3c3d47885fd744d84ba3abf3cfc0d6a9ea4f6c.tar.bz2
master-31e0f0ae-5e3c3d47885fd744d84ba3abf3cfc0d6a9ea4f6c.zip
kernel: add crypto-cmac
The bluetooth driver needs this new crypto lib in kernel 4.1 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 46180
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 22c790d2ee..074eb23233 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -408,6 +408,18 @@ endef
$(eval $(call KernelPackage,crypto-hmac))
+define KernelPackage/crypto-cmac
+ TITLE:=Support for Cipher-based Message Authentication Code (CMAC)
+ DEPENDS:=+kmod-crypto-hash
+ KCONFIG:=CONFIG_CRYPTO_CMAC
+ FILES:=$(LINUX_DIR)/crypto/cmac.ko
+ AUTOLOAD:=$(call AutoLoad,09,cmac)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-cmac))
+
+
define KernelPackage/crypto-gcm
TITLE:=GCM/GMAC CryptoAPI module
DEPENDS:=+kmod-crypto-ctr +kmod-crypto-ghash +kmod-crypto-null