summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-05 13:02:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-05 13:02:14 +0000
commit593c8c3c01eb3befa2af0ea8c2090b279248f636 (patch)
tree2a3ca97ed06602b194b7e93a59dcf9d7107502c2 /package/kernel/linux/modules/crypto.mk
parentf51dc17eddff60d46009ca85c2ee50c46ca7d9df (diff)
downloadmaster-31e0f0ae-593c8c3c01eb3befa2af0ea8c2090b279248f636.tar.gz
master-31e0f0ae-593c8c3c01eb3befa2af0ea8c2090b279248f636.tar.bz2
master-31e0f0ae-593c8c3c01eb3befa2af0ea8c2090b279248f636.zip
kernel/modules: add kmod-crypto-gcm
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> SVN-Revision: 43838
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 9d69cce9d5..73f36beaa1 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -400,6 +400,18 @@ endef
$(eval $(call KernelPackage,crypto-hmac))
+define KernelPackage/crypto-gcm
+ TITLE:=GCM/GMAC CryptoAPI module
+ DEPENDS:=+kmod-crypto-ctr +kmod-crypto-ghash +kmod-crypto-null
+ KCONFIG:=CONFIG_CRYPTO_GCM
+ FILES:=$(LINUX_DIR)/crypto/gcm.ko
+ AUTOLOAD:=$(call AutoLoad,09,gcm)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-gcm))
+
+
define KernelPackage/crypto-gf128
TITLE:=GF(2^128) multiplication functions CryptoAPI module
KCONFIG:=CONFIG_CRYPTO_GF128MUL