summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-11-15 21:33:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-11-15 21:33:54 +0000
commit54b305796d5e79842f224df1823b5a71a3717141 (patch)
tree6843c64bb877a0d02f7b89d1c1ae2c59bfca71c8 /package/kernel/linux/modules/crypto.mk
parent34558e6535d6d64cc237821f882470c5482a16a4 (diff)
downloadmaster-31e0f0ae-54b305796d5e79842f224df1823b5a71a3717141.tar.gz
master-31e0f0ae-54b305796d5e79842f224df1823b5a71a3717141.tar.bz2
master-31e0f0ae-54b305796d5e79842f224df1823b5a71a3717141.zip
kernel/modules: add OCTEON SHA256 module
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> SVN-Revision: 47477
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk9
1 files changed, 8 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index f5c58954b8..2328fac043 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -492,12 +492,19 @@ $(eval $(call KernelPackage,crypto-sha1))
define KernelPackage/crypto-sha256
TITLE:=SHA224 SHA256 digest CryptoAPI module
DEPENDS:=+kmod-crypto-hash
- KCONFIG:=CONFIG_CRYPTO_SHA256
+ KCONFIG:= \
+ CONFIG_CRYPTO_SHA256 \
+ CONFIG_CRYPTO_SHA256_OCTEON
FILES:=$(LINUX_DIR)/crypto/sha256_generic.ko
AUTOLOAD:=$(call AutoLoad,09,sha256_generic)
$(call AddDepends/crypto)
endef
+define KernelPackage/crypto-sha256/octeon
+ FILES+=$(LINUX_DIR)/arch/mips/cavium-octeon/crypto/octeon-sha256.ko
+ AUTOLOAD:=$(call AutoLoad,09,octeon-sha256)
+endef
+
$(eval $(call KernelPackage,crypto-sha256))