summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-12-02 22:19:31 +0000
committerJonas Gorski <jogo@openwrt.org>2015-12-02 22:19:31 +0000
commit4454a3fb6375cf1adf17f63a54cd7660bc40caa7 (patch)
tree075c1b7d37e501eef074479fc285aa104c87fce9 /package/kernel/linux/modules/crypto.mk
parent9c0ca6082dcfb2b4a78f4833a744bf30d3de6d59 (diff)
downloadmaster-31e0f0ae-4454a3fb6375cf1adf17f63a54cd7660bc40caa7.tar.gz
master-31e0f0ae-4454a3fb6375cf1adf17f63a54cd7660bc40caa7.tar.bz2
master-31e0f0ae-4454a3fb6375cf1adf17f63a54cd7660bc40caa7.zip
package: kernel: update dependencies for 4.4
Update dependencies for linux 4.4 and mark as broken where source code needs updating. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 47700
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 9626b21fdb..062afe7168 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -27,7 +27,7 @@ define KernelPackage/crypto-aead
CONFIG_CRYPTO_AEAD2
FILES:=$(LINUX_DIR)/crypto/aead.ko
AUTOLOAD:=$(call AutoLoad,09,aead,1)
- $(call AddDepends/crypto)
+ $(call AddDepends/crypto, +LINUX_4_4:kmod-crypto-null)
endef
$(eval $(call KernelPackage,crypto-aead))
@@ -258,7 +258,7 @@ $(eval $(call KernelPackage,crypto-hw-omap))
define KernelPackage/crypto-authenc
TITLE:=Combined mode wrapper for IPsec
- DEPENDS:=+kmod-crypto-manager
+ DEPENDS:=+kmod-crypto-manager +LINUX_4_4:kmod-crypto-null
KCONFIG:=CONFIG_CRYPTO_AUTHENC
FILES:=$(LINUX_DIR)/crypto/authenc.ko
AUTOLOAD:=$(call AutoLoad,09,authenc)
@@ -625,7 +625,7 @@ define KernelPackage/crypto-null
KCONFIG:=CONFIG_CRYPTO_NULL
FILES:=$(LINUX_DIR)/crypto/crypto_null.ko
AUTOLOAD:=$(call AutoLoad,09,crypto_null)
- $(call AddDepends/crypto,+kmod-crypto-manager)
+ $(call AddDepends/crypto, +kmod-crypto-hash)
endef
$(eval $(call KernelPackage,crypto-null))