summaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/crypto.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-29 04:32:01 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-29 04:32:01 +0000
commit196fb76a4c43692fb27e99586d2b4b9f6ef5ff55 (patch)
treeb2a27b7dbb8290bda08ce404cff778bc130b89d7 /package/kernel/linux/modules/crypto.mk
parent09aad60610d5887cb8ab03f550ad6450f017189f (diff)
downloadmaster-31e0f0ae-196fb76a4c43692fb27e99586d2b4b9f6ef5ff55.tar.gz
master-31e0f0ae-196fb76a4c43692fb27e99586d2b4b9f6ef5ff55.tar.bz2
master-31e0f0ae-196fb76a4c43692fb27e99586d2b4b9f6ef5ff55.zip
x86: make x86_64 a subtarget instead of a standalone target
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45115
Diffstat (limited to 'package/kernel/linux/modules/crypto.mk')
-rw-r--r--package/kernel/linux/modules/crypto.mk18
1 files changed, 11 insertions, 7 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index 4df2d7393a..d1ae061460 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -262,10 +262,12 @@ define KernelPackage/crypto-aes
$(call AddDepends/crypto)
endef
-define KernelPackage/crypto-aes/x86
- FILES+=$(LINUX_DIR)/arch/x86/crypto/aes-i586.ko
- AUTOLOAD:=$(call AutoLoad,09,aes-i586)
-endef
+ifndef CONFIG_TARGET_x86_64
+ define KernelPackage/crypto-aes/x86
+ FILES+=$(LINUX_DIR)/arch/x86/crypto/aes-i586.ko
+ AUTOLOAD:=$(call AutoLoad,09,aes-i586)
+ endef
+endif
$(eval $(call KernelPackage,crypto-aes))
@@ -530,9 +532,11 @@ define KernelPackage/crypto-misc
$(call AddDepends/crypto)
endef
-define KernelPackage/crypto-misc/x86
- FILES+=$(LINUX_DIR)/arch/x86/crypto/twofish-i586.ko
-endef
+ifndef CONFIG_TARGET_x86_64
+ define KernelPackage/crypto-misc/x86
+ FILES+=$(LINUX_DIR)/arch/x86/crypto/twofish-i586.ko
+ endef
+endif
$(eval $(call KernelPackage,crypto-misc))